summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b60a5de20..fdbfb1d7f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -368,6 +368,16 @@ else()
endif()
+#
+# Enable extra buildbot code (default=OFF)
+#
+option( ENABLE_EXTRA_BUILDBOT_CODE "enable extra buildbot code (default=OFF)" OFF )
+if( ENABLE_EXTRA_BUILDBOT_CODE )
+ set_property( CACHE GLOBAL_DEFINITIONS PROPERTY VALUE "${GLOBAL_DEFINITIONS} -DBUILDBOT" )
+ message( STATUS "Enabled extra BUILDBOT code" )
+endif()
+
+
#####################################################################
# package stuff
#