summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorflaviojs <flaviojs@54d463be-8e91-2dee-dedb-b68131a5f0ec>2012-04-23 03:52:52 +0000
committerflaviojs <flaviojs@54d463be-8e91-2dee-dedb-b68131a5f0ec>2012-04-23 03:52:52 +0000
commit2df8fa5ee4a0762dd41e04d7a6ecf1f29c008935 (patch)
tree47e05294aa14c813016621e8bfc319bd829b31cb /CMakeLists.txt
parent1a0163002e166a3c61253280c69a841559d837f8 (diff)
downloadhercules-2df8fa5ee4a0762dd41e04d7a6ecf1f29c008935.tar.gz
hercules-2df8fa5ee4a0762dd41e04d7a6ecf1f29c008935.tar.bz2
hercules-2df8fa5ee4a0762dd41e04d7a6ecf1f29c008935.tar.xz
hercules-2df8fa5ee4a0762dd41e04d7a6ecf1f29c008935.zip
Add ENABLE_EXTRA_BUILDBOT_CODE to CMakeLists.txt
git-svn-id: https://rathena.svn.sourceforge.net/svnroot/rathena/trunk@15940 54d463be-8e91-2dee-dedb-b68131a5f0ec
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b60a5de20..fdbfb1d7f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -368,6 +368,16 @@ else()
endif()
+#
+# Enable extra buildbot code (default=OFF)
+#
+option( ENABLE_EXTRA_BUILDBOT_CODE "enable extra buildbot code (default=OFF)" OFF )
+if( ENABLE_EXTRA_BUILDBOT_CODE )
+ set_property( CACHE GLOBAL_DEFINITIONS PROPERTY VALUE "${GLOBAL_DEFINITIONS} -DBUILDBOT" )
+ message( STATUS "Enabled extra BUILDBOT code" )
+endif()
+
+
#####################################################################
# package stuff
#