summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorgepard1984 <gepard1984@54d463be-8e91-2dee-dedb-b68131a5f0ec>2012-01-20 20:33:32 +0000
committergepard1984 <gepard1984@54d463be-8e91-2dee-dedb-b68131a5f0ec>2012-01-20 20:33:32 +0000
commit44d7606656a650dc43018b5c63bb56ad1f70e77c (patch)
treea34a45286714803911fe2bf55315c611a444e605 /configure.in
parenta02514bc54c044f141520118ffd7e0b6ff5ecae2 (diff)
downloadhercules-44d7606656a650dc43018b5c63bb56ad1f70e77c.tar.gz
hercules-44d7606656a650dc43018b5c63bb56ad1f70e77c.tar.bz2
hercules-44d7606656a650dc43018b5c63bb56ad1f70e77c.tar.xz
hercules-44d7606656a650dc43018b5c63bb56ad1f70e77c.zip
Merged TXT removal branch back to trunk.
* TXT save engine is removed and no longer supported. * See also tid:53926, tid:57717. git-svn-id: https://rathena.svn.sourceforge.net/svnroot/rathena/trunk@15503 54d463be-8e91-2dee-dedb-b68131a5f0ec
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in88
1 files changed, 33 insertions, 55 deletions
diff --git a/configure.in b/configure.in
index 8872e7c8c..3269537b2 100644
--- a/configure.in
+++ b/configure.in
@@ -8,7 +8,6 @@ AC_CONFIG_SRCDIR([src/common/cbasetypes.h])
AC_CONFIG_FILES([Makefile src/common/Makefile])
AC_CONFIG_FILES([3rdparty/mt19937ar/Makefile])
AC_CONFIG_FILES([src/char/Makefile src/login/Makefile])
-AC_CONFIG_FILES([src/char_sql/Makefile src/txt-converter/Makefile])
AC_CONFIG_FILES([src/map/Makefile src/plugins/Makefile src/tool/Makefile])
@@ -166,29 +165,22 @@ AC_ARG_ENABLE(
#
-# Enable/disable MySql and optionally specify the path to mysql_config (optional library)
+# Optionally specify the path to mysql_config
#
AC_ARG_WITH(
[mysql],
AC_HELP_STRING(
[--with-mysql@<:@=ARG@:>@],
- [use MySQL client library, optionally specify the path to the mysql_config executable (by default mysql is used if found)]
+ [optionally specify the path to the mysql_config executable]
),
[
- if test "$withval" = "no" ; then
- want_mysql="no"
- else
- want_mysql="yes"
- require_mysql="yes"
- if test "$withval" != "yes" ; then
- if test ! -x "$withval" ; then
- AC_MSG_ERROR([$withval is not an executable file])
- fi
- MYSQL_CONFIG_HOME="$withval"
+ if test "$withval" != "no" ; then
+ if test ! -x "$withval" ; then
+ AC_MSG_ERROR([$withval is not an executable file])
fi
+ MYSQL_CONFIG_HOME="$withval"
fi
- ],
- [want_mysql="yes" require_mysql="no"]
+ ]
)
@@ -632,52 +624,38 @@ fi
#
-# MySQL library (optional)
+# MySQL library
#
-if test "$want_mysql" = "no" ; then
- MYSQL_VERSION=""
- MYSQL_CFLAGS=""
- MYSQL_LIBS=""
- AC_MSG_NOTICE([ignoring MySQL (optional)])
-else
- if test -z "$MYSQL_CONFIG_HOME"; then
- AC_PATH_PROG([MYSQL_CONFIG_HOME], [mysql_config], [no])
- fi
+if test -z "$MYSQL_CONFIG_HOME"; then
+ AC_PATH_PROG([MYSQL_CONFIG_HOME], [mysql_config], [no])
+fi
- if test "$MYSQL_CONFIG_HOME" != "no" ; then
- MYSQL_VERSION="`$MYSQL_CONFIG_HOME --version`"
- if test "$manual_MYSQL_CFLAGS" = "no" ; then
- MYSQL_CFLAGS="`$MYSQL_CONFIG_HOME --include`"
- fi
- if test "$manual_MYSQL_LIBS" = "no" ; then
- MYSQL_LIBS="`$MYSQL_CONFIG_HOME --libs`"
- fi
- else
- MYSQL_VERSION="unknown"
+if test "$MYSQL_CONFIG_HOME" != "no" ; then
+ MYSQL_VERSION="`$MYSQL_CONFIG_HOME --version`"
+ if test "$manual_MYSQL_CFLAGS" = "no" ; then
+ MYSQL_CFLAGS="`$MYSQL_CONFIG_HOME --include`"
+ fi
+ if test "$manual_MYSQL_LIBS" = "no" ; then
+ MYSQL_LIBS="`$MYSQL_CONFIG_HOME --libs`"
fi
+else
+ MYSQL_VERSION="unknown"
+fi
- MYSQL_OLD_LDFLAGS="$LDFLAGS" ; LDFLAGS="$LDFLAGS $MYSQL_LIBS"
- MYSQL_OLD_CPPFLAGS="$CPPFLAGS" ; CPPFLAGS="$CPPFLAGS $MYSQL_CFLAGS"
- AC_CHECK_LIB([mysqlclient], [mysql_init], [HAVE_MYSQL="yes"], [])
- AC_CHECK_HEADER([mysql.h], [], [HAVE_MYSQL=""])
- CPPFLAGS="$MYSQL_OLD_CPPFLAGS"
- LDFLAGS="$MYSQL_OLD_LDFLAGS"
+MYSQL_OLD_LDFLAGS="$LDFLAGS" ; LDFLAGS="$LDFLAGS $MYSQL_LIBS"
+MYSQL_OLD_CPPFLAGS="$CPPFLAGS" ; CPPFLAGS="$CPPFLAGS $MYSQL_CFLAGS"
+AC_CHECK_LIB([mysqlclient], [mysql_init], [HAVE_MYSQL="yes"], [])
+AC_CHECK_HEADER([mysql.h], [], [HAVE_MYSQL=""])
+CPPFLAGS="$MYSQL_OLD_CPPFLAGS"
+LDFLAGS="$MYSQL_OLD_LDFLAGS"
- AC_MSG_CHECKING([MySQL library (optional)])
- if test "$HAVE_MYSQL" = "yes" ; then
- AC_MSG_RESULT([yes ($MYSQL_VERSION)])
- else
- AC_MSG_RESULT([no])
- if test "$require_mysql" = "yes" ; then
- AC_MSG_ERROR([MySQL not found or incompatible (requested)])
- else
- AC_MSG_NOTICE([disabling MySQL (optional)])
- MYSQL_VERSION=""
- MYSQL_CFLAGS=""
- MYSQL_LIBS=""
- fi
- fi
+AC_MSG_CHECKING([MySQL library (required)])
+if test "$HAVE_MYSQL" = "yes" ; then
+ AC_MSG_RESULT([yes ($MYSQL_VERSION)])
+else
+ AC_MSG_RESULT([no])
+ AC_MSG_ERROR([MySQL not found or incompatible])
fi
AC_SUBST([HAVE_MYSQL])