summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorgepard1984 <gepard1984@54d463be-8e91-2dee-dedb-b68131a5f0ec>2012-01-19 22:05:57 +0000
committergepard1984 <gepard1984@54d463be-8e91-2dee-dedb-b68131a5f0ec>2012-01-19 22:05:57 +0000
commita02514bc54c044f141520118ffd7e0b6ff5ecae2 (patch)
treedfe93655eac7e4e2839db311f86d8e035ba8e0b3 /configure.in
parent6fc8fc296c58e7a935fc6ee1d2775d02367edd95 (diff)
downloadhercules-a02514bc54c044f141520118ffd7e0b6ff5ecae2.tar.gz
hercules-a02514bc54c044f141520118ffd7e0b6ff5ecae2.tar.bz2
hercules-a02514bc54c044f141520118ffd7e0b6ff5ecae2.tar.xz
hercules-a02514bc54c044f141520118ffd7e0b6ff5ecae2.zip
* Added `--enable-buildbot` to configure.in (follow-up to r15128).
* Fixed TXT-removal branch configure and Makefile errors and removed TXT-only leftovers. * SQL libs are now required to configure/make TXT-removal branch. git-svn-id: https://rathena.svn.sourceforge.net/svnroot/rathena/trunk@15499 54d463be-8e91-2dee-dedb-b68131a5f0ec
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in33
1 files changed, 32 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 3aff089db..8872e7c8c 100644
--- a/configure.in
+++ b/configure.in
@@ -1,7 +1,7 @@
# -*- Autoconf -*-
# Process this file with autoconf to produce a configure script.
-AC_INIT(eAthena)
+AC_INIT(rAthena)
AC_REVISION($Revision$)
AC_PREREQ([2.59])
AC_CONFIG_SRCDIR([src/common/cbasetypes.h])
@@ -76,6 +76,26 @@ AC_ARG_ENABLE(
)
#
+# Buildbot
+#
+AC_ARG_ENABLE(
+ [buildbot],
+ AC_HELP_STRING(
+ [--enable-buildbot@<:@=ARG@:>@],
+ [(available options: yes, no)]
+ ),
+ [
+ enable_buildbot="$enableval"
+ case $enableval in
+ "no");;
+ "yes");;
+ *) AC_MSG_ERROR([[invalid argument --enable-buildbot=$enableval... stopping]]);;
+ esac
+ ],
+ [enable_buildbot="no"]
+)
+
+#
# RDTSC as Tick Source
#
AC_ARG_ENABLE(
@@ -511,6 +531,17 @@ case $enable_debug in
;;
esac
+#
+# Buildbot
+#
+case $enable_buildbot in
+ "no")
+ # default value
+ ;;
+ "yes")
+ CFLAGS="$CFLAGS -DBUILDBOT"
+ ;;
+esac
#
# RDTSC