summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 7d4a512b..8c3a9271 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -19,8 +19,6 @@ tmwserv_SOURCES = main.cpp \
netsession.cpp \
packet.h \
packet.cpp \
- sqlite/SQLiteWrapper.cpp \
- sqlite/SQLiteWrapper.h \
log.h \
log.cpp \
skill.h \
@@ -31,6 +29,12 @@ tmwserv_SOURCES = main.cpp \
script-squirrel.cpp \
storage.cpp storage.h
+
+if BUILD_SQLITE
+tmwserv_SOURCES += sqlite/SQLiteWrapper.cpp \
+ sqlite/SQLiteWrapper.h
+endif
+
# set the include path found by configure
INCLUDES= $(all_includes) $(SQLITE_CFLAGS)
LIBS = $(SQLITE_LIBS)