summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMateusz Kaduk <mateusz.kaduk@gmail.com>2005-05-23 07:30:50 +0000
committerMateusz Kaduk <mateusz.kaduk@gmail.com>2005-05-23 07:30:50 +0000
commit7594437a36acbdc7fb0c1a0e56b0954910c2543c (patch)
treeb2e1a9212f09ac1b6c1703a44658356bdaa2c24d /src/Makefile.am
parent5cf7a669530b9f328fa79c401575cdd0e14a523e (diff)
downloadmanaserv-7594437a36acbdc7fb0c1a0e56b0954910c2543c.tar.gz
manaserv-7594437a36acbdc7fb0c1a0e56b0954910c2543c.tar.bz2
manaserv-7594437a36acbdc7fb0c1a0e56b0954910c2543c.tar.xz
manaserv-7594437a36acbdc7fb0c1a0e56b0954910c2543c.zip
Building sqlite conditionaly
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 7d4a512b..8c3a9271 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -19,8 +19,6 @@ tmwserv_SOURCES = main.cpp \
netsession.cpp \
packet.h \
packet.cpp \
- sqlite/SQLiteWrapper.cpp \
- sqlite/SQLiteWrapper.h \
log.h \
log.cpp \
skill.h \
@@ -31,6 +29,12 @@ tmwserv_SOURCES = main.cpp \
script-squirrel.cpp \
storage.cpp storage.h
+
+if BUILD_SQLITE
+tmwserv_SOURCES += sqlite/SQLiteWrapper.cpp \
+ sqlite/SQLiteWrapper.h
+endif
+
# set the include path found by configure
INCLUDES= $(all_includes) $(SQLITE_CFLAGS)
LIBS = $(SQLITE_LIBS)