summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBen Longbons <b.r.longbons@gmail.com>2013-08-01 18:21:47 -0700
committerBen Longbons <b.r.longbons@gmail.com>2013-08-01 18:21:47 -0700
commita3405560a639e8ee90457d78a9b393dde91d8781 (patch)
tree8e0b6853ad6c7b2b847ce86d9c84a46e3e98a7c8 /setup.py
downloadattobuild-a3405560a639e8ee90457d78a9b393dde91d8781.tar.gz
attobuild-a3405560a639e8ee90457d78a9b393dde91d8781.tar.bz2
attobuild-a3405560a639e8ee90457d78a9b393dde91d8781.tar.xz
attobuild-a3405560a639e8ee90457d78a9b393dde91d8781.zip
Initial commit of the final draft of attoconf
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py22
1 files changed, 22 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..2086609
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,22 @@
+#!/usr/bin/env python
+
+from distutils.core import setup
+
+setup(
+ name='attoconf',
+ version='1.0',
+ description='A small and sensible replacement for GNU autoconf',
+ author='Ben Longbons',
+ author_email='b.r.longbons@gmail.com',
+ url='http://github.com/o11c/attoconf',
+ packages=[
+ 'attoconf',
+ ],
+ classifiers=[
+ 'Development Status :: 3 - Alpha',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: GNU General Public License v3 or later (GPLv3+)',
+ 'Programming Language :: Python :: 2 :: Only',
+ 'Topic :: Software Development :: Build Tools',
+ ],
+)