summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorflaviojs <flaviojs@54d463be-8e91-2dee-dedb-b68131a5f0ec>2011-07-22 14:54:37 +0000
committerflaviojs <flaviojs@54d463be-8e91-2dee-dedb-b68131a5f0ec>2011-07-22 14:54:37 +0000
commita751e7ba146eee3694169b8087306c93732689e6 (patch)
treeb355e7aa4ee2173100aaaa5e3e4390ce0dcf2fb8 /src/CMakeLists.txt
parentbf373f6054e0e3dd3b32a7ded8a3ae697902cbe1 (diff)
downloadhercules-a751e7ba146eee3694169b8087306c93732689e6.tar.gz
hercules-a751e7ba146eee3694169b8087306c93732689e6.tar.bz2
hercules-a751e7ba146eee3694169b8087306c93732689e6.tar.xz
hercules-a751e7ba146eee3694169b8087306c93732689e6.zip
* CMake: Added options BUILD_TXT_SERVERS, BUILD_SQL_SERVERS, BUILD_MAPCACHE.
git-svn-id: https://rathena.svn.sourceforge.net/svnroot/rathena/trunk@14921 54d463be-8e91-2dee-dedb-b68131a5f0ec
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 4233bcb12..7ec05e405 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1,5 +1,23 @@
+#
+# setup and static libraries
+#
add_subdirectory( common )
+if( HAVE_common_base )
+ option( BUILD_TXT_SERVERS "build txt server executables" ON )
+else()
+ message( STATUS "Disabled txt server targets (requires common_base)" )
+endif()
+if( HAVE_common_sql )
+ option( BUILD_SQL_SERVERS "build sql server executables" ON )
+else()
+ message( STATUS "Disabled sql server targets (requires common_sql)" )
+endif()
+
+
+#
+# targets
+#
add_subdirectory( login )
add_subdirectory( char )
add_subdirectory( char_sql )