summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorflaviojs <flaviojs@54d463be-8e91-2dee-dedb-b68131a5f0ec>2011-07-10 15:29:57 +0000
committerflaviojs <flaviojs@54d463be-8e91-2dee-dedb-b68131a5f0ec>2011-07-10 15:29:57 +0000
commitf817e3714747b39a364e99c536e0b802b24fd2c3 (patch)
tree4feb82dd35e6d4b647dde3716f3fb2463aef0398 /CMakeLists.txt
parentee66778144c8a069a04d5f77ec73dcab973c61d0 (diff)
downloadhercules-f817e3714747b39a364e99c536e0b802b24fd2c3.tar.gz
hercules-f817e3714747b39a364e99c536e0b802b24fd2c3.tar.bz2
hercules-f817e3714747b39a364e99c536e0b802b24fd2c3.tar.xz
hercules-f817e3714747b39a364e99c536e0b802b24fd2c3.zip
* CMake: lowered required version to 2.8.3 and moved custom cmake modules to 3rdparty/cmake.
git-svn-id: https://rathena.svn.sourceforge.net/svnroot/rathena/trunk@14897 54d463be-8e91-2dee-dedb-b68131a5f0ec
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt27
1 files changed, 25 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 523d445ef..1163ccddb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,3 +1,5 @@
+#####################################################################
+#
# "Getting Started with CMake", a tutorial video by Eric Wing.
# Part 1 of 6: http://www.youtube.com/watch?v=CLvZTyji_Uw
# Part 2 of 6: http://www.youtube.com/watch?v=gUW-RrRQjEg
@@ -11,8 +13,30 @@
# WITH_* : option to use an external package or not
# ENABLE_* : option to use an internal feature/code or not
# HAVE_* : internal variable indicating if we have and are using something
-cmake_minimum_required( VERSION 2.8.4 )
+#
+# Example (build in subdir 'build' and install to source dir):
+# mkdir build
+# cd build
+# cmake -G"Unix Makefiles" -DINSTALL_TO_SOURCE:bool=ON ..
+# make install
+# cd ..
+# rm -rf build
+#
+#####################################################################
+
+
+#cmake_minimum_required( VERSION 2.8.4 )
+# Functional changes from 2.8.3 to 2.8.4:
+# string(SUBSTRING) works with length -1 as "rest of string"
+# changes to some CPack generators
+# CYGWIN no longer defines WIN32
+# CMP0017: Prefer files from the CMake module directory when including from there.
+set( CMAKE_LEGACY_CYGWIN_WIN32 0 )
+cmake_minimum_required( VERSION 2.8.3 )
project( eAthena )
+if( CYGWIN )
+ unset( WIN32 )
+endif()
#
@@ -261,5 +285,4 @@ endif()
#
# subdirectories
#
-add_subdirectory( 3rdparty )
add_subdirectory( src )