summaryrefslogtreecommitdiff
path: root/dyecmd/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'dyecmd/CMakeLists.txt')
-rw-r--r--dyecmd/CMakeLists.txt28
1 files changed, 0 insertions, 28 deletions
diff --git a/dyecmd/CMakeLists.txt b/dyecmd/CMakeLists.txt
deleted file mode 100644
index 4856664..0000000
--- a/dyecmd/CMakeLists.txt
+++ /dev/null
@@ -1,28 +0,0 @@
-CMAKE_MINIMUM_REQUIRED(VERSION 2.6)
-
-PROJECT(MANA_DYECOMMAND)
-
-IF (NOT VERSION)
- SET(VERSION 1.0.0)
-ENDIF()
-
-STRING(REPLACE "." " " _VERSION ${VERSION})
-SEPARATE_ARGUMENTS(_VERSION)
-LIST(LENGTH _VERSION _LEN)
-IF(NOT (_LEN EQUAL 4 OR _LEN EQUAL 3))
- MESSAGE(FATAL_ERROR "Version needs to be in the form MAJOR.MINOR.RELEASE[.BUILD]")
-ENDIF()
-
-LIST(GET _VERSION 0 VER_MAJOR)
-LIST(GET _VERSION 1 VER_MINOR)
-LIST(GET _VERSION 2 VER_RELEASE)
-IF(_LEN EQUAL 4)
- LIST(GET _VERSION 3 VER_BUILD)
-ELSE()
- SET(VER_BUILD 0)
-ENDIF()
-
-# where to look for cmake modules
-SET(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/CMake/Modules)
-
-ADD_SUBDIRECTORY(src)