summaryrefslogtreecommitdiff
path: root/src/map/sql/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/map/sql/CMakeLists.txt')
-rw-r--r--src/map/sql/CMakeLists.txt39
1 files changed, 39 insertions, 0 deletions
diff --git a/src/map/sql/CMakeLists.txt b/src/map/sql/CMakeLists.txt
new file mode 100644
index 000000000..13b1af32c
--- /dev/null
+++ b/src/map/sql/CMakeLists.txt
@@ -0,0 +1,39 @@
+
+#
+# map sql
+#
+if( USE_ZLIB AND USE_MYSQL )
+message ( STATUS "Creating target map-server_sql" )
+set( LIBRARIES ${GLOBAL_LIBRARIES} ${ZLIB_LIBRARIES} ${MYSQL_LIBRARIES} )
+set( INCLUDE_DIRS ${GLOBAL_INCLUDE_DIRS} ${MT19937AR_INCLUDE_DIRS} ${ZLIB_INCLUDE_DIRS} ${MYSQL_INCLUDE_DIRS} ${COMMON_INCLUDE_DIRS} )
+set( DEFINITIONS ${GLOBAL_DEFINITIONS} )
+if( USE_PCRE )
+ message( STATUS "Using PCRE" )
+ list( APPEND LIBRARIES ${PCRE_LIBRARIES} )
+ list( APPEND INCLUDE_DIRS ${PCRE_INCLUDE_DIRS} )
+endif()
+if( PACKETVER )
+ message( STATUS "Using PACKETVER=${PACKETVER}" )
+ list( APPEND DEFINITIONS PACKETVER=${PACKETVER} )
+endif()
+if( WIN32 )
+ list( APPEND LIBRARIES "oldnames.lib" "ws2_32.lib" )
+ list( APPEND INCLUDE_DIRS ${MSINTTYPES_INCLUDE_DIRS} )
+endif()
+set( SOURCE_FILES ${MT19937AR_SOURCES} ${COMMON_SOURCES} ${COMMON_SQL_SOURCES} ${MAP_SOURCES} ${MAP_SQL_SOURCES} )
+source_group( 3rdparty FILES ${MT19937AR_SOURCES} )
+source_group( common FILES ${COMMON_SOURCES} ${COMMON_SQL_SOURCES} )
+source_group( map FILES ${MAP_SOURCES} ${MAP_SQL_SOURCES} )
+include_directories( ${INCLUDE_DIRS} )
+add_executable( map-server_sql ${SOURCE_FILES} )
+target_link_libraries( map-server_sql ${LIBRARIES} )
+set_target_properties( map-server_sql PROPERTIES COMPILE_DEFINITIONS "${DEFINITIONS}" )
+if( INSTALL_RUN_DATA )
+ install( TARGETS map-server_sql
+ DESTINATION ${CMAKE_INSTALL_PREFIX}
+ COMPONENT "map-server_sql" )
+endif()
+message ( STATUS "Creating target map-server_sql - done" )
+else()
+message ( STATUS "Skipping target map-server_sql (requires ZLIB and MYSQL; optional PCRE)" )
+endif()