summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in34
1 files changed, 34 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 9e13e89ab..d9353f51c 100644
--- a/configure.in
+++ b/configure.in
@@ -189,6 +189,29 @@ AC_ARG_ENABLE(
#
+# Renewal
+#
+AC_ARG_ENABLE(
+ [renewal],
+ AC_HELP_STRING(
+ [--disable-renewal],
+ [
+ Disable Ragnarok Renewal support (override settings in src/config/renewal.h)
+ ]
+ ),
+ [
+ enable_renewal="$enableval"
+ case $enableval in
+ "no");;
+ "yes");;
+ *) AC_MSG_ERROR([[invalid argument --enable-renewal=$enableval... stopping]]);;
+ esac
+ ],
+ [enable_renewal="yes"]
+)
+
+
+#
# Optionally set the max number of network conenctions
# the core will be support
#
@@ -757,6 +780,17 @@ case $enable_profiler in
;;
esac
+#
+# Renewal
+#
+case $enable_renewal in
+ "no")
+ CFLAGS="$CFLAGS -DDISABLE_RENEWAL"
+ ;;
+ "yes")
+ # default value
+ ;;
+esac
#
# zlib library (required)