summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorHaru <haru@dotalux.com>2013-08-05 16:36:45 +0200
committerHaru <haru@dotalux.com>2013-08-08 02:21:25 +0200
commitdefac0ef9714121a872ab48c3f6c4ddd177ae509 (patch)
tree7e6a37f2284256da0bedb48eb3f5137cbf739b83 /configure.in
parenta702c55f219519c1d9410f823bd7a9e4c6be256b (diff)
downloadhercules-defac0ef9714121a872ab48c3f6c4ddd177ae509.tar.gz
hercules-defac0ef9714121a872ab48c3f6c4ddd177ae509.tar.bz2
hercules-defac0ef9714121a872ab48c3f6c4ddd177ae509.tar.xz
hercules-defac0ef9714121a872ab48c3f6c4ddd177ae509.zip
Enabled Pre-Renewal builds in the CI buildbot
Both Renewal and Pre-Renewal branches will now be built and tested. Signed-off-by: Haru <haru@dotalux.com>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in34
1 files changed, 34 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 9e13e89ab..d9353f51c 100644
--- a/configure.in
+++ b/configure.in
@@ -189,6 +189,29 @@ AC_ARG_ENABLE(
#
+# Renewal
+#
+AC_ARG_ENABLE(
+ [renewal],
+ AC_HELP_STRING(
+ [--disable-renewal],
+ [
+ Disable Ragnarok Renewal support (override settings in src/config/renewal.h)
+ ]
+ ),
+ [
+ enable_renewal="$enableval"
+ case $enableval in
+ "no");;
+ "yes");;
+ *) AC_MSG_ERROR([[invalid argument --enable-renewal=$enableval... stopping]]);;
+ esac
+ ],
+ [enable_renewal="yes"]
+)
+
+
+#
# Optionally set the max number of network conenctions
# the core will be support
#
@@ -757,6 +780,17 @@ case $enable_profiler in
;;
esac
+#
+# Renewal
+#
+case $enable_renewal in
+ "no")
+ CFLAGS="$CFLAGS -DDISABLE_RENEWAL"
+ ;;
+ "yes")
+ # default value
+ ;;
+esac
#
# zlib library (required)