summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in33
1 files changed, 32 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 3aff089db..8872e7c8c 100644
--- a/configure.in
+++ b/configure.in
@@ -1,7 +1,7 @@
# -*- Autoconf -*-
# Process this file with autoconf to produce a configure script.
-AC_INIT(eAthena)
+AC_INIT(rAthena)
AC_REVISION($Revision$)
AC_PREREQ([2.59])
AC_CONFIG_SRCDIR([src/common/cbasetypes.h])
@@ -76,6 +76,26 @@ AC_ARG_ENABLE(
)
#
+# Buildbot
+#
+AC_ARG_ENABLE(
+ [buildbot],
+ AC_HELP_STRING(
+ [--enable-buildbot@<:@=ARG@:>@],
+ [(available options: yes, no)]
+ ),
+ [
+ enable_buildbot="$enableval"
+ case $enableval in
+ "no");;
+ "yes");;
+ *) AC_MSG_ERROR([[invalid argument --enable-buildbot=$enableval... stopping]]);;
+ esac
+ ],
+ [enable_buildbot="no"]
+)
+
+#
# RDTSC as Tick Source
#
AC_ARG_ENABLE(
@@ -511,6 +531,17 @@ case $enable_debug in
;;
esac
+#
+# Buildbot
+#
+case $enable_buildbot in
+ "no")
+ # default value
+ ;;
+ "yes")
+ CFLAGS="$CFLAGS -DBUILDBOT"
+ ;;
+esac
#
# RDTSC