summaryrefslogtreecommitdiff
path: root/src/tool/CMakeLists.txt
diff options
context:
space:
mode:
authorflaviojs <flaviojs@54d463be-8e91-2dee-dedb-b68131a5f0ec>2011-07-22 14:54:37 +0000
committerflaviojs <flaviojs@54d463be-8e91-2dee-dedb-b68131a5f0ec>2011-07-22 14:54:37 +0000
commita751e7ba146eee3694169b8087306c93732689e6 (patch)
treeb355e7aa4ee2173100aaaa5e3e4390ce0dcf2fb8 /src/tool/CMakeLists.txt
parentbf373f6054e0e3dd3b32a7ded8a3ae697902cbe1 (diff)
downloadhercules-a751e7ba146eee3694169b8087306c93732689e6.tar.gz
hercules-a751e7ba146eee3694169b8087306c93732689e6.tar.bz2
hercules-a751e7ba146eee3694169b8087306c93732689e6.tar.xz
hercules-a751e7ba146eee3694169b8087306c93732689e6.zip
* CMake: Added options BUILD_TXT_SERVERS, BUILD_SQL_SERVERS, BUILD_MAPCACHE.
git-svn-id: https://rathena.svn.sourceforge.net/svnroot/rathena/trunk@14921 54d463be-8e91-2dee-dedb-b68131a5f0ec
Diffstat (limited to 'src/tool/CMakeLists.txt')
-rw-r--r--src/tool/CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/src/tool/CMakeLists.txt b/src/tool/CMakeLists.txt
index 4dc500fc7..55ea2d267 100644
--- a/src/tool/CMakeLists.txt
+++ b/src/tool/CMakeLists.txt
@@ -3,6 +3,11 @@
# mapcache
#
if( WITH_ZLIB )
+ option( BUILD_MAPCACHE "build mapcache executable" ON )
+else()
+ message( STATUS "Disabled mapcache target (required ZLIB)" )
+endif()
+if( BUILD_MAPCACHE )
message( STATUS "Creating target mapcache" )
set( COMMON_HEADERS
${COMMON_MINI_HEADERS}
@@ -35,7 +40,4 @@ if( INSTALL_COMPONENT_RUNTIME )
endif( INSTALL_COMPONENT_RUNTIME )
set( TARGET_LIST ${TARGET_LIST} mapcache CACHE INTERNAL "" )
message( STATUS "Creating target mapcache - done" )
-else()
-message( STATUS "Skipping target mapcache (requires ZLIB)" )
-unset( HAVE_mapcache CACHE )
-endif()
+endif( BUILD_MAPCACHE )