summaryrefslogtreecommitdiff
path: root/src/map/CMakeLists.txt
diff options
context:
space:
mode:
authorflaviojs <flaviojs@54d463be-8e91-2dee-dedb-b68131a5f0ec>2011-07-01 15:43:58 +0000
committerflaviojs <flaviojs@54d463be-8e91-2dee-dedb-b68131a5f0ec>2011-07-01 15:43:58 +0000
commit0361920446e9311979b5187abf123ba8e055d944 (patch)
tree02d41953674d66ae58e0a5fae453f218b7934ae2 /src/map/CMakeLists.txt
parent1c39635e7f5788b4777ee9f07d45b2228edeb899 (diff)
downloadhercules-0361920446e9311979b5187abf123ba8e055d944.tar.gz
hercules-0361920446e9311979b5187abf123ba8e055d944.tar.bz2
hercules-0361920446e9311979b5187abf123ba8e055d944.tar.xz
hercules-0361920446e9311979b5187abf123ba8e055d944.zip
* CMake: marked executables as different components and other miscellaneous changes. [FlavioJS]
git-svn-id: https://rathena.svn.sourceforge.net/svnroot/rathena/trunk@14877 54d463be-8e91-2dee-dedb-b68131a5f0ec
Diffstat (limited to 'src/map/CMakeLists.txt')
-rw-r--r--src/map/CMakeLists.txt14
1 files changed, 12 insertions, 2 deletions
diff --git a/src/map/CMakeLists.txt b/src/map/CMakeLists.txt
index e5589a30e..7189bbdd7 100644
--- a/src/map/CMakeLists.txt
+++ b/src/map/CMakeLists.txt
@@ -1,5 +1,7 @@
+#
# setup
+#
set( MT19937AR_SOURCES
"${MT19937AR_SOURCE_DIR}/mt19937ar.c"
)
@@ -68,7 +70,9 @@ set( MAP_SQL_SOURCES
)
+#
# map txt
+#
if( USE_ZLIB )
message ( STATUS "Creating target map-server" )
set( LIBRARIES ${GLOBAL_LIBRARIES} ${ZLIB_LIBRARIES} )
@@ -96,7 +100,9 @@ add_executable( map-server ${SOURCE_FILES} )
target_link_libraries( map-server ${LIBRARIES} )
set_target_properties( map-server PROPERTIES COMPILE_DEFINITIONS "${DEFINITIONS}" )
if( INSTALL_RUN_DATA )
- install( TARGETS map-server DESTINATION ${CMAKE_INSTALL_PREFIX} )
+ install( TARGETS map-server
+ DESTINATION ${CMAKE_INSTALL_PREFIX}
+ COMPONENT "map-server" )
endif()
message ( STATUS "Creating target map-server - done" )
else()
@@ -104,7 +110,9 @@ message ( STATUS "Skipping target map-server (requires ZLIB; optional PCRE)" )
endif()
+#
# map sql
+#
if( USE_ZLIB AND USE_MYSQL )
message ( STATUS "Creating target map-server_sql" )
set( LIBRARIES ${GLOBAL_LIBRARIES} ${ZLIB_LIBRARIES} ${MYSQL_LIBRARIES} )
@@ -132,7 +140,9 @@ add_executable( map-server_sql ${SOURCE_FILES} )
target_link_libraries( map-server_sql ${LIBRARIES} )
set_target_properties( map-server_sql PROPERTIES COMPILE_DEFINITIONS "${DEFINITIONS}" )
if( INSTALL_RUN_DATA )
- install( TARGETS map-server_sql DESTINATION ${CMAKE_INSTALL_PREFIX} )
+ install( TARGETS map-server_sql
+ DESTINATION ${CMAKE_INSTALL_PREFIX}
+ COMPONENT "map-server_sql" )
endif()
message ( STATUS "Creating target map-server_sql - done" )
else()