summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorHaru <haru@dotalux.com>2014-10-24 00:42:18 +0200
committerHaru <haru@dotalux.com>2014-10-24 00:51:58 +0200
commite1e5bd338fe507d23ac72c964efa5c7009c30bba (patch)
tree4b7f72903afc941e9a70461f39ad848e721d0f90 /configure.in
parentbf2d0b4295b5197ce6d303e8124c470613df94bf (diff)
downloadhercules-e1e5bd338fe507d23ac72c964efa5c7009c30bba.tar.gz
hercules-e1e5bd338fe507d23ac72c964efa5c7009c30bba.tar.bz2
hercules-e1e5bd338fe507d23ac72c964efa5c7009c30bba.tar.xz
hercules-e1e5bd338fe507d23ac72c964efa5c7009c30bba.zip
Added support for other libmysqlclient variants
- This allows Hercules to correctly detect MariaDB and other drop-in replacements in distributions that rename their libmysqlclient (i.e. Debian / Ubuntu renaming it to libmariadbclient). - Closes issue #368 - Due to a bug in Ubuntu 14.04 LTS (incorrect output by the mariadb-provided version of `mysql_config --libs` and missing dependencies of libmariadbclient-dev), users of said distribution will have to manually specify ./configure LIBS="-lssl -lcrypto" as well as manually install the libssl-dev package, if they wish to use libmariadbclient-dev, as it will be unable to link otherwise (note: this issue isn't Hercules-specific) - Special thanks to Andrei Karas Signed-off-by: Haru <haru@dotalux.com>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index cd1dbea1d..ec3b1f735 100644
--- a/configure.in
+++ b/configure.in
@@ -1256,12 +1256,12 @@ else
MYSQL_VERSION="unknown"
fi
-MYSQL_OLD_LDFLAGS="$LDFLAGS" ; LDFLAGS="$LDFLAGS $MYSQL_LIBS"
+MYSQL_OLD_LIBS="$LIBS" ; LIBS="$LIBS $MYSQL_LIBS"
MYSQL_OLD_CPPFLAGS="$CPPFLAGS" ; CPPFLAGS="$CPPFLAGS $MYSQL_CFLAGS"
-AC_CHECK_LIB([mysqlclient], [mysql_init], [HAVE_MYSQL="yes"], [])
+AC_CHECK_FUNC([mysql_init], [HAVE_MYSQL="yes"])
AC_CHECK_HEADER([mysql.h], [], [HAVE_MYSQL=""])
CPPFLAGS="$MYSQL_OLD_CPPFLAGS"
-LDFLAGS="$MYSQL_OLD_LDFLAGS"
+LIBS="$MYSQL_OLD_LIBS"
AC_MSG_CHECKING([MySQL library (required)])
if test "$HAVE_MYSQL" = "yes" ; then