summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorFlavioJS <FlavioJS@54d463be-8e91-2dee-dedb-b68131a5f0ec>2008-04-13 17:46:24 +0000
committerFlavioJS <FlavioJS@54d463be-8e91-2dee-dedb-b68131a5f0ec>2008-04-13 17:46:24 +0000
commitdc99d88746c2175dfa5007ae2cbbde795dd357d1 (patch)
treedfb5320822c41918b10283cc250a8d94ddca5a81 /configure.in
parent3470551740241bdee3b6a9f5098c31143fa64897 (diff)
downloadhercules-dc99d88746c2175dfa5007ae2cbbde795dd357d1.tar.gz
hercules-dc99d88746c2175dfa5007ae2cbbde795dd357d1.tar.bz2
hercules-dc99d88746c2175dfa5007ae2cbbde795dd357d1.tar.xz
hercules-dc99d88746c2175dfa5007ae2cbbde795dd357d1.zip
* Changes to the configure script:
- clarified how --with-zlib is used - added --enable-packetver to set the PACKETVER define (used often enough to get it's own option, but unnecessary since it can be set with CFLAGS) - added -g compiler option to --enable-debug git-svn-id: https://rathena.svn.sourceforge.net/svnroot/rathena/trunk@12578 54d463be-8e91-2dee-dedb-b68131a5f0ec
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in27
1 files changed, 25 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 2751d945e..ac0e7b436 100644
--- a/configure.in
+++ b/configure.in
@@ -37,6 +37,20 @@ AC_ARG_ENABLE(
#
+# packetver
+#
+AC_ARG_ENABLE(
+ [packetver],
+ AC_HELP_STRING(
+ [--enable-packetver=ARG],
+ [Sets the PACKETVER define of the map-server. (see src/map/clif.h)]
+ ),
+ [enable_packetver="$enableval"],
+ [enable_packetver=""]
+)
+
+
+#
# mapregsql
#
AC_ARG_ENABLE(
@@ -139,7 +153,8 @@ AC_ARG_WITH(
[zlib],
AC_HELP_STRING(
[--with-zlib=DIR],
- [root directory path of zlib installation (defaults to /usr/local or /usr if not found in /usr/local)]
+ [root directory path of zlib installation (defaults to /usr/local or /usr if not found in /usr/local).
+ Assumes that the header files are in DIR/include and the library files are in DIR/lib]
),
[
test -n "$withval" && ZLIB_HOME="$withval"
@@ -273,6 +288,14 @@ esac
#
+# Packetver
+#
+if test -n "$enable_packetver" ; then
+ CFLAGS="$CFLAGS -DPACKETVER=$enable_packetver"
+fi
+
+
+#
# Mapregsql
#
if test "$enable_mapregsql" = "yes" ; then
@@ -284,7 +307,7 @@ fi
# Debug
#
if test "$enable_debug" = "yes" ; then
- CFLAGS="$CFLAGS -DDEBUG"
+ CFLAGS="$CFLAGS -g -DDEBUG"
fi