summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorFlavioJS <FlavioJS@54d463be-8e91-2dee-dedb-b68131a5f0ec>2007-11-08 09:26:46 +0000
committerFlavioJS <FlavioJS@54d463be-8e91-2dee-dedb-b68131a5f0ec>2007-11-08 09:26:46 +0000
commit9eb222426c4275cf35648ac8dc2e6c83cdbba14c (patch)
tree132f2cb9e34cbe382d8f285b4d4a25e52def2acd /configure.in
parent48d5e34204d9b077bc22cd095deb1006e621d930 (diff)
downloadhercules-9eb222426c4275cf35648ac8dc2e6c83cdbba14c.tar.gz
hercules-9eb222426c4275cf35648ac8dc2e6c83cdbba14c.tar.bz2
hercules-9eb222426c4275cf35648ac8dc2e6c83cdbba14c.tar.xz
hercules-9eb222426c4275cf35648ac8dc2e6c83cdbba14c.zip
* Updated configure script:
- small correction to the help text of --with-mysql and --with-pcre - added the -Wno-switch compiler option to suppress the "enumeration value '%s' not handled in switch" warnings git-svn-id: https://rathena.svn.sourceforge.net/svnroot/rathena/trunk@11695 54d463be-8e91-2dee-dedb-b68131a5f0ec
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in23
1 files changed, 18 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 092e22f3a..dc5da9c54 100644
--- a/configure.in
+++ b/configure.in
@@ -2,7 +2,7 @@
# Process this file with autoconf to produce a configure script.
AC_INIT(eAthena)
-AC_REVISION($Revision$)
+AC_REVISION($Revision: 11695$)
AC_PREREQ([2.61])
AC_CONFIG_SRCDIR([src/common/cbasetypes.h])
AC_CONFIG_FILES([Makefile src/common/Makefile])
@@ -17,8 +17,8 @@ AC_CONFIG_FILES([src/map/Makefile src/plugins/Makefile src/tool/Makefile])
AC_ARG_WITH(
[mysql],
AC_HELP_STRING(
- [--with-mysql=@<:@ARG@:>@],
- [use MySQL client library @<:@default=yes@:>@, optionally specify path to the mysql_config executable]
+ [--with-mysql@<:@=ARG@:>@],
+ [use MySQL client library, optionally specify path to the mysql_config executable (by default mysql is used if found)]
),
[
if test "$withval" = "no" ; then
@@ -41,8 +41,8 @@ AC_ARG_WITH(
AC_ARG_WITH(
[pcre],
AC_HELP_STRING(
- [--with-pcre=@<:@ARG@:>@],
- [use PCRE library @<:@default=yes@:>@, optionally specify the root directory path of pcre installation]
+ [--with-pcre@<:@=ARG@:>@],
+ [use PCRE library, optionally specify the root directory path of pcre installation (by default pcre is used if found)]
),
[
if test "$withval" = "no" ; then
@@ -146,6 +146,19 @@ AC_COMPILE_IFELSE(
)
+AC_MSG_CHECKING([whether $CC supports -Wno-switch])
+OLD_CFLAGS="$CFLAGS"
+CFLAGS="$CFLAGS -Wno-switch"
+AC_COMPILE_IFELSE(
+ [int foo;],
+ [AC_MSG_RESULT([yes])],
+ [
+ AC_MSG_RESULT([no])
+ CFLAGS="$OLD_CFLAGS"
+ ]
+)
+
+
###############################################################################
# Checks for libraries and header files.