summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2016-02-19 20:18:50 +0300
committerAndrei Karas <akaras@inbox.ru>2016-02-19 20:18:50 +0300
commit98f4fcb5ba1819ace7cfe6ad4ac9fdc4e7754ba9 (patch)
treea02c83fefe9a8a9be0931f690accb8128bcb36f5 /configure.in
parentfd7cd2c4b768745ef711c0b28b0c7b03ac57e486 (diff)
downloadhercules-98f4fcb5ba1819ace7cfe6ad4ac9fdc4e7754ba9.tar.gz
hercules-98f4fcb5ba1819ace7cfe6ad4ac9fdc4e7754ba9.tar.bz2
hercules-98f4fcb5ba1819ace7cfe6ad4ac9fdc4e7754ba9.tar.xz
hercules-98f4fcb5ba1819ace7cfe6ad4ac9fdc4e7754ba9.zip
Add noreturn attributes.
Also add compiler flag for check for missing noreturn attributes.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 9618113eb..e23b6c44b 100644
--- a/configure.in
+++ b/configure.in
@@ -459,10 +459,17 @@ AC_LANG([C])
# -Wcast-qual use for check wrong casts. It cant be added by default, because some casts must be wrong.
# -Wconversion warning: conversion to 'long unsigned int' from 'int' may change the sign of the result
# -Wfloat-equal comparing floating point with == or != is unsafe
+# -Wpedantic different pedantic checks. Not all can be fixed in nice way.
+# attributes suggestion
+# -Wsuggest-attribute=const -Wsuggest-attribute=format -Wsuggest-attribute=pure
+
# flags what can be used but now return no warnings: -Warray-bounds -Wbool-compare -Wcast-align
# -Wchar-subscripts -Wchkp -Wclobbered -Wcomment -Wdisabled-optimization -Wempty-body
# -Werror-implicit-function-declaration -Wignored-qualifiers
-# -Winit-self
+# -Wjump-misses-init -Wlogical-op -Wmissing-field-initializers -Wmissing-parameter-type
+# -Wnested-externs -Wold-style-declaration -Wold-style-definition -Woverlength-strings -Woverride-init
+# -Wredundant-decls -Wstack-protector -Wstrict-prototypes
+# -Winit-self -Wpointer-arith
CFLAGS="$CFLAGS -pipe -ffast-math -Wall -Wextra -Wno-sign-compare"
CPPFLAGS="$CPPFLAGS -I../common"
@@ -811,6 +818,7 @@ AC_CHECK_COMPILER_WFLAG(format)
AC_CHECK_COMPILER_WFLAG(format-signedness)
AC_CHECK_COMPILER_WFLAG(format-y2k)
AC_CHECK_COMPILER_WFLAG(missing-include-dirs)
+AC_CHECK_COMPILER_WFLAG(suggest-attribute=noreturn)
AC_CHECK_COMPILER_WNOFLAG(format-nonliteral)
AC_CHECK_COMPILER_WNOFLAG(switch)
AC_CHECK_COMPILER_WNOFLAG(missing-field-initializers)