summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorHaru <haru@dotalux.com>2016-02-06 18:09:58 +0100
committerHaru <haru@dotalux.com>2016-02-06 18:50:36 +0100
commit730fede2da1ca573ff716c77a5d9b1d0989adc6e (patch)
tree24e284d03b45b893d76b3f834888bcb75a761630 /configure.in
parentdfdf6b91839c88d9ca1071d63337d33757a87f4c (diff)
downloadhercules-730fede2da1ca573ff716c77a5d9b1d0989adc6e.tar.gz
hercules-730fede2da1ca573ff716c77a5d9b1d0989adc6e.tar.bz2
hercules-730fede2da1ca573ff716c77a5d9b1d0989adc6e.tar.xz
hercules-730fede2da1ca573ff716c77a5d9b1d0989adc6e.zip
Added /usr/local path to the header and library search paths
- This fixes PCRE search failures on FreeBSD and on OS X with Homebrew - Thanks to ultramage Signed-off-by: Haru <haru@dotalux.com>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index b4a5a110c..9dd53ab95 100644
--- a/configure.in
+++ b/configure.in
@@ -481,6 +481,18 @@ CFLAGS="$CFLAGS -pipe -ffast-math -Wall -Wextra -Wno-sign-compare"
CPPFLAGS="$CPPFLAGS -I../common"
LDFLAGS="$LDFLAGS"
+# Add /usr/local to the library and header search path, where appropriate
+case `uname` in
+ Darwin*|*BSD*)
+ if test -d /usr/local/include ; then
+ CPPFLAGS="$CPPFLAGS -I/usr/local/include"
+ fi
+ if test -d /usr/local/lib ; then
+ LDFLAGS="$LDFLAGS -L/usr/local/lib"
+ fi
+ ;;
+esac
+
AC_C_BIGENDIAN(
[AC_MSG_ERROR([[bigendian is not supported... stopping]])],
,