summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorHaru <haru@dotalux.com>2014-02-25 20:44:22 +0100
committerHaru <haru@dotalux.com>2014-03-07 06:41:01 +0100
commit66c40e84fe1514c71e043b139cebcb45616a2854 (patch)
tree5444182e1047bd420d94c5abf0fddc77e722a29c /configure.in
parentd30ceb11e52efea9536bb048ac2140d923b0a728 (diff)
downloadhercules-66c40e84fe1514c71e043b139cebcb45616a2854.tar.gz
hercules-66c40e84fe1514c71e043b139cebcb45616a2854.tar.bz2
hercules-66c40e84fe1514c71e043b139cebcb45616a2854.tar.xz
hercules-66c40e84fe1514c71e043b139cebcb45616a2854.zip
Updated configure script to support non-x86 platforms
Signed-off-by: Haru <haru@dotalux.com>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 1fc2d0e29..6755e3ca5 100644
--- a/configure.in
+++ b/configure.in
@@ -481,8 +481,29 @@ AC_RUN_IFELSE(
])],
[
AC_MSG_RESULT([yes])
+ AC_MSG_CHECKING([whether $CC supports -march=i686 (and we can run it)])
+ OLD_CFLAGS="$CFLAGS"
+ OLD_LDFLAGS="$LDFLAGS"
CFLAGS="$CFLAGS -march=i686"
LDFLAGS="$LDFLAGS -march=i686"
+ AC_RUN_IFELSE(
+ [AC_LANG_SOURCE([
+ int main(int argc, char **argv) { return 0; }
+ ])],
+ [
+ AC_MSG_RESULT([yes])
+ ],
+ [
+ AC_MSG_RESULT([no])
+ CFLAGS="$OLD_CFLAGS"
+ LDFLAGS="$OLD_LDFLAGS"
+ ],
+ [
+ AC_MSG_RESULT([guessing no])
+ CFLAGS="$OLD_CFLAGS"
+ LDFLAGS="$OLD_LDFLAGS"
+ ]
+ )
],
[
AC_MSG_RESULT([no])