summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorFlavioJS <FlavioJS@54d463be-8e91-2dee-dedb-b68131a5f0ec>2007-09-27 15:24:06 +0000
committerFlavioJS <FlavioJS@54d463be-8e91-2dee-dedb-b68131a5f0ec>2007-09-27 15:24:06 +0000
commit61aacc083393bead3227a049b57fb9e76186c7c5 (patch)
tree5872c3c351086969f539a105906568c1f39183b9 /configure.in
parenta46c1fbcb1b7df32c678af8f0bbfda801d6142dc (diff)
downloadhercules-61aacc083393bead3227a049b57fb9e76186c7c5.tar.gz
hercules-61aacc083393bead3227a049b57fb9e76186c7c5.tar.bz2
hercules-61aacc083393bead3227a049b57fb9e76186c7c5.tar.xz
hercules-61aacc083393bead3227a049b57fb9e76186c7c5.zip
* Loot code using charid's instead of id's in pick priority.
* configure script using svn:eol-style LF and require mysql/pcre when --with-mysql/pcre is used. Added a forgotten file from r11311. (script_commands.txt) Note: charid's are globally unique, id's are equal for characters in the same account. git-svn-id: https://rathena.svn.sourceforge.net/svnroot/rathena/trunk@11312 54d463be-8e91-2dee-dedb-b68131a5f0ec
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in30
1 files changed, 20 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index 8e5cec894..092e22f3a 100644
--- a/configure.in
+++ b/configure.in
@@ -23,14 +23,15 @@ AC_ARG_WITH(
[
if test "$withval" = "no" ; then
want_mysql="no"
- elif test "$withval" = "yes" ; then
- want_mysql="yes"
else
want_mysql="yes"
- MYSQL_CONFIG_HOME="$withval"
+ require_mysql="yes"
+ if test "$withval" != "yes" ; then
+ MYSQL_CONFIG_HOME="$withval"
+ fi
fi
],
- [want_mysql="yes"]
+ [want_mysql="yes" require_mysql="no"]
)
@@ -46,14 +47,15 @@ AC_ARG_WITH(
[
if test "$withval" = "no" ; then
want_pcre="no"
- elif test "$withval" = "yes" ; then
- want_pcre="yes"
else
want_pcre="yes"
- PCRE_HOME="$withval"
+ require_pcre="yes"
+ if test "$withval" != "yes" ; then
+ PCRE_HOME="$withval"
+ fi
fi
],
- [want_pcre="yes"]
+ [want_pcre="yes" require_pcre="no"]
)
@@ -176,7 +178,11 @@ else
fi
else
AC_MSG_RESULT([no])
- AC_MSG_NOTICE([disabling MySQL (optional)])
+ if test "$require_mysql" = "yes" ; then
+ AC_MSG_ERROR([MySQL not found (requested)])
+ else
+ AC_MSG_NOTICE([disabling MySQL (optional)])
+ fi
fi
fi
@@ -219,7 +225,11 @@ else
AC_MSG_RESULT([yes])
else
AC_MSG_RESULT([no])
- AC_MSG_NOTICE([disabling PCRE (optional)])
+ if test "$require_pcre" = "yes" ; then
+ AC_MSG_ERROR([PCRE not found (requested)])
+ else
+ AC_MSG_NOTICE([disabling PCRE (optional)])
+ fi
fi
fi