summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorHaru <haru@dotalux.com>2013-10-08 20:55:27 +0200
committerHaru <haru@dotalux.com>2013-10-09 05:49:04 +0200
commit5fdbee45f634d5d5b29ffa3144c8ac4881c10578 (patch)
tree87ff7e5bab40749666f44d69b24da3b75a1c1f12 /configure.in
parent540c7071234d44875bf397fb80d2f18c4f4db1bf (diff)
downloadhercules-5fdbee45f634d5d5b29ffa3144c8ac4881c10578.tar.gz
hercules-5fdbee45f634d5d5b29ffa3144c8ac4881c10578.tar.bz2
hercules-5fdbee45f634d5d5b29ffa3144c8ac4881c10578.tar.xz
hercules-5fdbee45f634d5d5b29ffa3144c8ac4881c10578.zip
Added HPMHookGen tool, to re-generate hooks include files
- Slightly reformatted the include files (as produced by the new tool) - You normally won't need to use the generation tool, but in case you do, the software requirements are: * A Unix-compatible system (cygwin may work, or may not), capable to use the Hercules configure/make build system * perl (the perl executable must be in your $PATH) * doxygen (the command-line doxygen executable must be in your $PATH) - The generation tool was developed in collaboration with Ind (originally in php, the file here included is a tweaked version ported to perl) Signed-off-by: Haru <haru@dotalux.com>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 486390eaa..bd80bd43f 100644
--- a/configure.in
+++ b/configure.in
@@ -10,6 +10,7 @@ AC_CONFIG_FILES([3rdparty/mt19937ar/Makefile 3rdparty/libconfig/Makefile])
AC_CONFIG_FILES([src/char/Makefile src/login/Makefile])
AC_CONFIG_FILES([src/map/Makefile src/plugins/Makefile src/tool/Makefile])
AC_CONFIG_FILES([src/test/Makefile])
+AC_CONFIG_FILES([tools/HPMHookGen/Makefile])
AC_GNU_SOURCE
@@ -992,6 +993,13 @@ AC_SUBST([HAVE_PCRE])
AC_SUBST([PCRE_LIBS])
AC_SUBST([PCRE_CFLAGS])
+#
+# Doxygen, perl (for HPMHookGen)
+#
+
+AC_CHECK_PROG([HAVE_DOXYGEN],[doxygen],[yes],[no])
+
+AC_CHECK_PROG([HAVE_PERL],[perl],[yes],[no])
#
# Host specific stuff