summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2016-01-16 23:16:54 +0300
committerAndrei Karas <akaras@inbox.ru>2016-01-21 19:39:37 +0300
commit5ce1b0ec7c0a8267bba7b163af5c7e4556fb3390 (patch)
treef219810e9bfd6bb0f069c28234b1ea6c84502c40 /configure.in
parent0ed2d09e9aa88af01698707fd701363bdbd92b4b (diff)
downloadhercules-5ce1b0ec7c0a8267bba7b163af5c7e4556fb3390.tar.gz
hercules-5ce1b0ec7c0a8267bba7b163af5c7e4556fb3390.tar.bz2
hercules-5ce1b0ec7c0a8267bba7b163af5c7e4556fb3390.tar.xz
hercules-5ce1b0ec7c0a8267bba7b163af5c7e4556fb3390.zip
Enable pcre by default in configure and show error if pcre missing.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in74
1 files changed, 5 insertions, 69 deletions
diff --git a/configure.in b/configure.in
index bfcc27322..7b89bbce4 100644
--- a/configure.in
+++ b/configure.in
@@ -444,33 +444,6 @@ AC_ARG_WITH(
#
-# Enable/disable PCRE and optionally specify the path (optional library)
-#
-AC_ARG_WITH(
- [pcre],
- AC_HELP_STRING(
- [--with-pcre@<:@=ARG@:>@],
- [use PCRE library, optionally specify the full path of pcre installation directory (by default pcre is used if found)]
- ),
- [
- if test "$withval" = "no" ; then
- want_pcre="no"
- else
- want_pcre="yes"
- require_pcre="yes"
- if test "$withval" != "yes" ; then
- if test ! -d "$withval" ; then
- AC_MSG_ERROR([$withval is not a directoy])
- fi
- PCRE_HOME="$withval"
- fi
- fi
- ],
- [want_pcre="yes" require_pcre="no"]
-)
-
-
-#
# Specify the path of the zlib library (required library)
#
AC_ARG_WITH(
@@ -1317,47 +1290,10 @@ AC_SUBST([MYSQL_LIBS])
#
# PCRE library (optional)
#
-##TODO PCRE version
-PCRE_LIBS=""
-PCRE_CFLAGS=""
-
-if test "$want_pcre" = "no" ; then
- AC_MSG_NOTICE([ignoring PCRE (optional)])
-else
- if test -z "$PCRE_HOME" ; then
- AC_CHECK_LIB([pcre], [pcre_study], [HAVE_PCRE="yes"], [])
- if test "$HAVE_PCRE" = "yes" ; then
- PCRE_LIBS="-lpcre"
- PCRE_CFLAGS="-DPCRE_SUPPORT"
- fi
- else
- PCRE_OLD_LDFLAGS="$LDFLAGS" ; LDFLAGS="$LDFLAGS -L$PCRE_HOME/lib"
- PCRE_OLD_CPPFLAGS="$CPPFLAGS" ; CPPFLAGS="$CPPFLAGS -I$PCRE_HOME/include"
- AC_CHECK_LIB(pcre, pcre_compile, [HAVE_PCRE="yes"], [])
- CPPFLAGS="$PCRE_OLD_CPPFLAGS"
- LDFLAGS="$PCRE_OLD_LDFLAGS"
- if test "$HAVE_PCRE" = "yes" ; then
- PCRE_LIBS="-L$PCRE_HOME/lib -lpcre"
- test -d "$PCRE_HOME/include" && PCRE_CFLAGS="-I$PCRE_HOME/include -DPCRE_SUPPORT"
- fi
- fi
- AC_MSG_CHECKING([PCRE library (optional)])
- if test "$HAVE_PCRE" = "yes" ; then
- AC_MSG_RESULT([yes])
- else
- AC_MSG_RESULT([no])
- if test "$require_pcre" = "yes" ; then
- AC_MSG_ERROR([PCRE not found or incompatible (requested)])
- else
- AC_MSG_NOTICE([disabling PCRE (optional)])
- fi
- fi
-fi
-
-AC_SUBST([HAVE_PCRE])
-AC_SUBST([PCRE_LIBS])
-AC_SUBST([PCRE_CFLAGS])
+AC_MSG_CHECKING([PCRE library])
+AC_CHECK_LIB(pcre, pcre_study, , AC_MSG_ERROR([PCRE not found or incompatible]))
+CFLAGS="$CFLAGS -DPCRE_SUPPORT"
#
# static Support test
@@ -1371,9 +1307,9 @@ if test "$enable_static" != "no" ; then
OLD_LDFLAGS="$LDFLAGS"
OLD_LIBS="$LIBS"
- CFLAGS="$OLD_CFLAGS $MYSQL_CFLAGS $PCRE_CFLAGS -static"
+ CFLAGS="$OLD_CFLAGS $MYSQL_CFLAGS -static"
LDFLAGS="$OLD_LDFLAGS -static"
- LIBS="$OLD_LIBS $MYSQL_LIBS $PCRE_LIBS"
+ LIBS="$OLD_LIBS $MYSQL_LIBS"
AC_MSG_CHECKING([whether $CC supports -static])
AC_RUN_IFELSE(