summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorshennetsind <ind@henn.et>2013-01-21 10:58:27 -0200
committershennetsind <ind@henn.et>2013-01-21 10:58:27 -0200
commit49d70063f846775e1609228d83fde2016b89737f (patch)
tree3fa5f58f105f39bd06b3143ef53d8b6d61fa8052 /configure.in
parente6ac0ecf225d839ed67335f6dc7c15cd0d296df0 (diff)
downloadhercules-49d70063f846775e1609228d83fde2016b89737f.tar.gz
hercules-49d70063f846775e1609228d83fde2016b89737f.tar.bz2
hercules-49d70063f846775e1609228d83fde2016b89737f.tar.xz
hercules-49d70063f846775e1609228d83fde2016b89737f.zip
Reverting SVN r17061
Making --enable-debug useful once again. in r17061 lighta made --enable-debug enforce -wconversion, -Wno-switch, and other options (instead of making them optional) and by doing that lighta cluttered --enable-debug output making it incredibly hard to find important errors Signed-off-by: shennetsind <ind@henn.et>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in31
1 files changed, 15 insertions, 16 deletions
diff --git a/configure.in b/configure.in
index 055b04e37..5444be663 100644
--- a/configure.in
+++ b/configure.in
@@ -331,7 +331,7 @@ AC_PATH_PROG(AR, ar)
AC_LANG([C])
-CFLAGS="$CFLAGS -pipe -ffast-math -Wall"
+CFLAGS="$CFLAGS -pipe -ffast-math -Wall -Wno-sign-compare"
CPPFLAGS="$CPPFLAGS -I../common"
@@ -420,13 +420,12 @@ OLD_CFLAGS="$CFLAGS"
CFLAGS="$CFLAGS -Wno-unused-parameter"
AC_COMPILE_IFELSE(
[int foo;],
- [AC_MSG_RESULT([no])],
+ [AC_MSG_RESULT([yes])],
[
- AC_MSG_RESULT([yes])
- PROD_WARN="$PROD_WARN -Wno-unused-parameter"
+ AC_MSG_RESULT([no])
+ CFLAGS="$OLD_CFLAGS"
]
)
-CFLAGS="$OLD_CFLAGS"
#
@@ -478,18 +477,19 @@ AC_COMPILE_IFELSE(
[int foo;],
[
AC_MSG_RESULT([yes])
- PROD_WARN="$PROD_WARN -Wno-pointer-sign"
+ CFLAGS="$OLD_CFLAGS -Wno-pointer-sign"
],
[
AC_MSG_RESULT([no])
+ CFLAGS="$OLD_CFLAGS"
]
)
],
[
- AC_MSG_RESULT([no])
+ AC_MSG_RESULT([no])
+ CFLAGS="$OLD_CFLAGS"
]
)
-CFLAGS="$OLD_CFLAGS"
AC_MSG_CHECKING([whether $CC supports -Wno-switch])
@@ -497,14 +497,13 @@ OLD_CFLAGS="$CFLAGS"
CFLAGS="$CFLAGS -Wno-switch"
AC_COMPILE_IFELSE(
[int foo;],
- [ AC_MSG_RESULT([yes])
- PROD_WARN="$PROD_WARN -Wno-switch"
- ],
+ [AC_MSG_RESULT([yes])],
[
AC_MSG_RESULT([no])
+ CFLAGS="$OLD_CFLAGS"
]
)
-CFLAGS="$OLD_CFLAGS"
+
AC_MSG_CHECKING([whether $CC supports -fPIC])
OLD_CFLAGS="$CFLAGS"
@@ -605,10 +604,10 @@ fi
case $enable_debug in
"no")
# default value
- CFLAGS="$CFLAGS -Wno-unused -Wno-parentheses $PROD_WARN"
+ CFLAGS="$CFLAGS -Wno-unused -Wno-parentheses"
;;
"yes")
- CFLAGS="$CFLAGS -g -DDEBUG -Wconversion"
+ CFLAGS="$CFLAGS -g -DDEBUG"
;;
"gdb")
CFLAGS="$CFLAGS -ggdb -DDEBUG"
@@ -855,7 +854,7 @@ else
AC_MSG_RESULT([no])
fi
-AC_MSG_NOTICE([PROD_WARN= $PROD_WARN])
-AC_MSG_NOTICE([Configure finish, CFLAG= $CFLAGS])
+
+
###############################################################################
AC_OUTPUT