summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorblacksirius <blacksirius@54d463be-8e91-2dee-dedb-b68131a5f0ec>2012-06-12 00:59:55 +0000
committerblacksirius <blacksirius@54d463be-8e91-2dee-dedb-b68131a5f0ec>2012-06-12 00:59:55 +0000
commit49586af4b75b96010380576fe9ce0a9b67a83ac2 (patch)
treeafebe591c3a1a372f66422f495f5e1fd0538032e /configure.in
parent0598cc569db02ee93d7fc0470defecb64e995f5c (diff)
downloadhercules-49586af4b75b96010380576fe9ce0a9b67a83ac2.tar.gz
hercules-49586af4b75b96010380576fe9ce0a9b67a83ac2.tar.bz2
hercules-49586af4b75b96010380576fe9ce0a9b67a83ac2.tar.xz
hercules-49586af4b75b96010380576fe9ce0a9b67a83ac2.zip
added new networking subsystem (early stage - files are not compiled yet during normal build!)
Note The files i added / modifications i did, are not affecting a normal build nothing gets changed yet! Linux 2.5+ only yet. git-svn-id: https://rathena.svn.sourceforge.net/svnroot/rathena/trunk@16271 54d463be-8e91-2dee-dedb-b68131a5f0ec
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in28
1 files changed, 28 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index e602db19f..5444be663 100644
--- a/configure.in
+++ b/configure.in
@@ -189,6 +189,34 @@ AC_ARG_ENABLE(
#
+# Optionally set the max number of network conenctions
+# the core will be support
+#
+AC_ARG_WITH(
+ [maxconn],
+ AC_HELP_STRING(
+ [--with-maxconn@<:@=ARG@:>@],
+ [optionally set the maximum connections the core can handle (default: 16384) NOT USED YET - EXPERIMENTAL]
+ ),
+ [
+ if test "$withval" == "no"; then
+ CFLAGS="$CFLAGS -DMAXCONN=16384"
+ else
+
+ if ! test "$withval" -ge 0 -o "$withval" -lt 0 2>&- ; then
+ AC_MSG_ERROR([Invalid argument --with-maxconn=$withval ... stopping])
+ else
+ CFLAGS="$CFLAGS -DMAXCONN=$withval"
+ fi
+ fi
+ ],
+ [
+ CFLAGS="$CFLAGS -DMAXCONN=16384"
+ ]
+)
+
+
+#
# Optionally specify the path to mysql_config
#
AC_ARG_WITH(