summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorHaru <haru@dotalux.com>2013-07-14 15:39:12 +0200
committerHaru <haru@dotalux.com>2013-07-14 15:59:45 +0200
commit3462ce6bf3efcc25eb3d4d449a45b89b64a3e70f (patch)
treef3b6c04bf5c7e5306f466a57d1d2f7d0b9eb9e11 /configure.in
parent9d3dbd508739b329931c951a7a5dab974adf4f54 (diff)
downloadhercules-3462ce6bf3efcc25eb3d4d449a45b89b64a3e70f.tar.gz
hercules-3462ce6bf3efcc25eb3d4d449a45b89b64a3e70f.tar.bz2
hercules-3462ce6bf3efcc25eb3d4d449a45b89b64a3e70f.tar.xz
hercules-3462ce6bf3efcc25eb3d4d449a45b89b64a3e70f.zip
Updated package name to Hercules in the autoconf script
- Replaced old SVN version string with a git-compatible one - Fixed configure.in warnings on autoconf 2.68 or newer (wrapped code snippets in AC_LANG_SOURCE calls, as recommended by autoconf) - Re-generated configure script with autoconf 2.69 Signed-off-by: Haru <haru@dotalux.com>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in48
1 files changed, 24 insertions, 24 deletions
diff --git a/configure.in b/configure.in
index d98badbfb..9e13e89ab 100644
--- a/configure.in
+++ b/configure.in
@@ -1,8 +1,8 @@
# -*- Autoconf -*-
# Process this file with autoconf to produce a configure script.
-AC_INIT(rAthena)
-AC_REVISION($Revision$)
+AC_INIT(Hercules)
+AC_REVISION([m4_esyscmd_s([type git >/dev/null 2>&1 && git describe --always 2>/dev/null || echo '(unknown version)'])])
AC_PREREQ([2.59])
AC_CONFIG_SRCDIR([src/common/cbasetypes.h])
AC_CONFIG_FILES([Makefile src/common/Makefile])
@@ -371,12 +371,12 @@ fi
#
AC_MSG_CHECKING([whether $CC produces 32bit code])
AC_RUN_IFELSE(
- [
+ [AC_LANG_SOURCE([
int main(int argc, char **argv){
if(sizeof(void*) == 4) return 0;
else return 1;
}
- ],
+ ])],
[
AC_MSG_RESULT([yes])
CFLAGS="$CFLAGS -march=i686"
@@ -397,14 +397,14 @@ AC_RUN_IFELSE(
#
AC_MSG_CHECKING([whether $CC supports __thread specifier (TLS)])
AC_RUN_IFELSE(
- [
+ [AC_LANG_SOURCE([
__thread int g_Test = -1;
int main(int argc, char **argv){
g_Test = 0;
return g_Test;
}
- ],
+ ])],
[
AC_MSG_RESULT([yes])
CFLAGS="$CFLAGS -DHAS_TLS"
@@ -419,7 +419,7 @@ AC_MSG_CHECKING([whether $CC supports -Wno-unused-parameter])
OLD_CFLAGS="$CFLAGS"
CFLAGS="$CFLAGS -Wno-unused-parameter"
AC_COMPILE_IFELSE(
- [int foo;],
+ [AC_LANG_SOURCE([int foo;])],
[AC_MSG_RESULT([yes])],
[
AC_MSG_RESULT([no])
@@ -441,11 +441,11 @@ if test "$enable_lto" != "no" ; then
AC_MSG_CHECKING([whether $CC supports -flto])
AC_RUN_IFELSE(
- [
+ [AC_LANG_SOURCE([
int main(int argc, char **argv){
return 0;
}
- ],
+ ])],
[
AC_MSG_RESULT([yes])
],
@@ -466,7 +466,7 @@ AC_MSG_CHECKING([whether $CC supports -Wno-pointer-sign])
OLD_CFLAGS="$CFLAGS"
CFLAGS="$CFLAGS -Wno-pointer-sign"
AC_COMPILE_IFELSE(
- [int foo;],
+ [AC_LANG_SOURCE([int foo;])],
[
AC_MSG_RESULT([yes])
AC_MSG_CHECKING([whether $CC can actually use -Wno-pointer-sign])
@@ -474,7 +474,7 @@ AC_COMPILE_IFELSE(
# Note: -Werror must be before -Wno-pointer-sign, otherwise it does not do anything
CFLAGS="$OLD_CFLAGS -Werror -Wno-pointer-sign"
AC_COMPILE_IFELSE(
- [int foo;],
+ [AC_LANG_SOURCE([int foo;])],
[
AC_MSG_RESULT([yes])
CFLAGS="$OLD_CFLAGS -Wno-pointer-sign"
@@ -496,7 +496,7 @@ AC_MSG_CHECKING([whether $CC supports -Wno-switch])
OLD_CFLAGS="$CFLAGS"
CFLAGS="$CFLAGS -Wno-switch"
AC_COMPILE_IFELSE(
- [int foo;],
+ [AC_LANG_SOURCE([int foo;])],
[AC_MSG_RESULT([yes])],
[
AC_MSG_RESULT([no])
@@ -509,7 +509,7 @@ AC_MSG_CHECKING([whether $CC supports -fPIC])
OLD_CFLAGS="$CFLAGS"
CFLAGS="$CFLAGS -fPIC"
AC_COMPILE_IFELSE(
- [int foo;],
+ [AC_LANG_SOURCE([int foo;])],
[
AC_MSG_RESULT([yes])
compiler_supports_pic="yes"
@@ -533,14 +533,14 @@ fi
# default
CFLAGS="$my_shared_test_flags -shared"
AC_LINK_IFELSE(
- [[
+ [AC_LANG_SOURCE([
int bar = 0;
int foo(void)
{
return bar;
}
- ]],
+ ])],
[
compiler_shared_objects="-shared"
]
@@ -548,14 +548,14 @@ AC_LINK_IFELSE(
# BeOS specific
CFLAGS="$my_shared_test_flags -nostart"
AC_LINK_IFELSE(
- [[
+ [AC_LANG_SOURCE([
int bar = 0;
int foo(void)
{
return bar;
}
- ]],
+ ])],
[
compiler_shared_objects="-nostart"
]
@@ -580,14 +580,14 @@ OLD_CFLAGS="$CFLAGS"
CFLAGS="$CFLAGS $SOFLAGS"
WITH_PLUGINS="yes"
AC_LINK_IFELSE(
- [[
+ [AC_LANG_SOURCE([
int bar = 0;
int foo(void)
{
return bar;
}
- ]],
+ ])],
[
AC_MSG_RESULT([no])
CFLAGS="$OLD_CFLAGS"
@@ -597,14 +597,14 @@ AC_LINK_IFELSE(
# Verify if -shared really fails due to lack of -fPIC or something else
CFLAGS="$CFLAGS -fPIC"
AC_LINK_IFELSE(
- [[
+ [AC_LANG_SOURCE([
int bar = 0;
int foo(void)
{
return bar;
}
- ]],
+ ])],
[
AC_MSG_RESULT([yes])
CFLAGS="$OLD_CFLAGS -fPIC"
@@ -634,7 +634,7 @@ AC_MSG_CHECKING([whether $CC supports -fno-strict-aliasing])
OLD_CFLAGS="$CFLAGS"
CFLAGS="$CFLAGS -fno-strict-aliasing"
AC_COMPILE_IFELSE(
- [int foo;],
+ [AC_LANG_SOURCE([int foo;])],
[AC_MSG_RESULT([yes])],
[
AC_MSG_RESULT([no])
@@ -792,7 +792,7 @@ AC_SEARCH_LIBS([clock_gettime], [rt])
if test "$ac_cv_search_clock_gettime" != "no" ; then
AC_MSG_CHECKING([whether CLOCK_MONOTONIC is supported and works])
AC_RUN_IFELSE(
- [
+ [AC_LANG_SOURCE([
#include <sys/time.h>
#include <time.h>
#include <unistd.h>
@@ -802,7 +802,7 @@ if test "$ac_cv_search_clock_gettime" != "no" ; then
struct timespec tval;
return clock_gettime(CLOCK_MONOTONIC, &tval);
}
- ],
+ ])],
[
AC_MSG_RESULT([yes])
CFLAGS="$CFLAGS -DHAVE_MONOTONIC_CLOCK"