summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorHaru <haru@dotalux.com>2016-02-06 18:15:23 +0100
committerHaru <haru@dotalux.com>2016-02-06 18:53:38 +0100
commit2f4b1d7f15c8835545c791f09bac94bfae7e43b8 (patch)
treecbe6b767c743d64faa493cd5a06e6f8c00d779ab /configure.in
parent8ca4506ee9ad4bfd490d1e9a7ab2cfb02f1ba3d7 (diff)
downloadhercules-2f4b1d7f15c8835545c791f09bac94bfae7e43b8.tar.gz
hercules-2f4b1d7f15c8835545c791f09bac94bfae7e43b8.tar.bz2
hercules-2f4b1d7f15c8835545c791f09bac94bfae7e43b8.tar.xz
hercules-2f4b1d7f15c8835545c791f09bac94bfae7e43b8.zip
Removed special handling of zlib in the configure script
Now it's handled like all other libraries, and no longer adds an useless -I/usr/include option Signed-off-by: Haru <haru@dotalux.com>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in29
1 files changed, 2 insertions, 27 deletions
diff --git a/configure.in b/configure.in
index 729a8f38e..c8bc3a864 100644
--- a/configure.in
+++ b/configure.in
@@ -443,27 +443,6 @@ AC_ARG_WITH(
)
-#
-# Specify the path of the zlib library (required library)
-#
-AC_ARG_WITH(
- [zlib],
- AC_HELP_STRING(
- [--with-zlib=DIR],
- [root directory path of zlib installation (defaults to /usr/local or /usr if not found in /usr/local).
- Assumes that the header files are in DIR/include and the library files are in DIR/lib]
- ),
- [
- test -n "$withval" && ZLIB_HOME="$withval"
- ],
- [
- ZLIB_HOME=/usr/local
- test ! -f "${ZLIB_HOME}/include/zlib.h" && ZLIB_HOME=/usr
- ]
-)
-
-
-
###############################################################################
# Check for programs and types.
#
@@ -1173,12 +1152,8 @@ fi
#
# zlib library (required)
#
-if test -n "${ZLIB_HOME}" ; then
- LDFLAGS="$LDFLAGS -L${ZLIB_HOME}/lib"
- CPPFLAGS="$CPPFLAGS -I${ZLIB_HOME}/include"
-fi
-AC_SEARCH_LIBS([inflateEnd], [z], [],[AC_MSG_ERROR([zlib library not found or incompatible, please specify the correct path with --with-zlib=DIR... stopping])])
-AC_CHECK_HEADER([zlib.h], [], [AC_MSG_ERROR([zlib header not found, please specify the correct path with --with-zlib=DIR... stopping])])
+AC_SEARCH_LIBS([inflateEnd], [z], [],[AC_MSG_ERROR([zlib library not found or incompatible... stopping])])
+AC_CHECK_HEADER([zlib.h], [], [AC_MSG_ERROR([zlib header not found, please specify the correct path with... stopping])])
#