summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorHaru <haru@dotalux.com>2015-12-02 21:06:53 +0100
committerHaru <haru@dotalux.com>2015-12-02 21:08:21 +0100
commit1e2f24a2fcb13b8a2fe06f4cc829670303760929 (patch)
tree30451ce67ff9d99ac943a8ad785126e2b0f0930a /configure.in
parent60dc92a6f2367fe6d75b0e7e6227d4fa5baaa60b (diff)
downloadhercules-1e2f24a2fcb13b8a2fe06f4cc829670303760929.tar.gz
hercules-1e2f24a2fcb13b8a2fe06f4cc829670303760929.tar.bz2
hercules-1e2f24a2fcb13b8a2fe06f4cc829670303760929.tar.xz
hercules-1e2f24a2fcb13b8a2fe06f4cc829670303760929.zip
Fixed an issue with the HPMDataCheck when PCRE is enabled
- Follow-up to 300668d, thanks to AnnieRuru Signed-off-by: Haru <haru@dotalux.com>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 5bb0dff65..aa7f74783 100644
--- a/configure.in
+++ b/configure.in
@@ -1309,6 +1309,7 @@ else
AC_CHECK_LIB([pcre], [pcre_study], [HAVE_PCRE="yes"], [])
if test "$HAVE_PCRE" = "yes" ; then
PCRE_LIBS="-lpcre"
+ PCRE_CFLAGS="-DPCRE_SUPPORT"
fi
else
PCRE_OLD_LDFLAGS="$LDFLAGS" ; LDFLAGS="$LDFLAGS -L$PCRE_HOME/lib"
@@ -1318,7 +1319,7 @@ else
LDFLAGS="$PCRE_OLD_LDFLAGS"
if test "$HAVE_PCRE" = "yes" ; then
PCRE_LIBS="-L$PCRE_HOME/lib -lpcre"
- test -d "$PCRE_HOME/include" && PCRE_CFLAGS="-I$PCRE_HOME/include"
+ test -d "$PCRE_HOME/include" && PCRE_CFLAGS="-I$PCRE_HOME/include -DPCRE_SUPPORT"
fi
fi
AC_MSG_CHECKING([PCRE library (optional)])