summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorHaru <haru@dotalux.com>2015-08-13 03:40:06 +0200
committerHaru <haru@dotalux.com>2015-08-13 04:15:58 +0200
commit1b4d33767fde9c55aa2e32f1a313688dc48a6ad4 (patch)
tree60d6a99177d72584e03c24f47af5f29a02fed623 /configure.in
parent08e100ec056ef7f8dabbbe33d3de14410c25f367 (diff)
downloadhercules-1b4d33767fde9c55aa2e32f1a313688dc48a6ad4.tar.gz
hercules-1b4d33767fde9c55aa2e32f1a313688dc48a6ad4.tar.bz2
hercules-1b4d33767fde9c55aa2e32f1a313688dc48a6ad4.tar.xz
hercules-1b4d33767fde9c55aa2e32f1a313688dc48a6ad4.zip
Added check for execinfo.h/backtrace() to the configure script
- This fixes compilation on systems such as FreeBSD, where -lexecinfo is necessary, or Cygwin, where execinfo.h is not available. Signed-off-by: Haru <haru@dotalux.com>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d17f5b4a7..8567c6bcb 100644
--- a/configure.in
+++ b/configure.in
@@ -1268,6 +1268,21 @@ AC_SEARCH_LIBS([pthread_attr_destroy], [pthread], [], [AC_MSG_ERROR([pthread lib
AC_SEARCH_LIBS([pthread_cancel], [pthread], [], [AC_MSG_ERROR([pthread library not found or incompatible])])
AC_SEARCH_LIBS([pthread_join], [pthread], [], [AC_MSG_ERROR([pthread library not found or incompatible])])
+# execinfo (backtrace)
+AC_CHECK_HEADERS([execinfo.h],
+ [
+ AC_SEARCH_LIBS([backtrace],
+ [execinfo],
+ [
+ CFLAGS="$CFLAGS -DHAVE_EXECINFO"
+ ],
+ [
+ ]
+ )
+ ],
+ [
+ ]
+)
#
# MySQL library