summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorYommy <Yommy@54d463be-8e91-2dee-dedb-b68131a5f0ec>2010-03-16 21:42:14 +0000
committerYommy <Yommy@54d463be-8e91-2dee-dedb-b68131a5f0ec>2010-03-16 21:42:14 +0000
commit09b5ddd71e1daa21c8e186207f7f3d1a4e3b11ed (patch)
tree2f8a4a2115cdd04678387af34ff3a1e3a2c6e2c1 /configure.in
parent33c698258a8a54483348ae8acc47d596603920ca (diff)
downloadhercules-09b5ddd71e1daa21c8e186207f7f3d1a4e3b11ed.tar.gz
hercules-09b5ddd71e1daa21c8e186207f7f3d1a4e3b11ed.tar.bz2
hercules-09b5ddd71e1daa21c8e186207f7f3d1a4e3b11ed.tar.xz
hercules-09b5ddd71e1daa21c8e186207f7f3d1a4e3b11ed.zip
added --enable-rdtsc configure option to enhance timer performance, especially in virtualized environments; default disabled - credits to sirius_black
git-svn-id: https://rathena.svn.sourceforge.net/svnroot/rathena/trunk@14265 54d463be-8e91-2dee-dedb-b68131a5f0ec
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in37
1 files changed, 37 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index c881f5610..4892ee141 100644
--- a/configure.in
+++ b/configure.in
@@ -74,6 +74,30 @@ AC_ARG_ENABLE(
[enable_debug="no"]
)
+#
+# RDTSC as Tick Source
+#
+AC_ARG_ENABLE(
+ [rdtsc],
+ AC_HELP_STRING(
+ [--enable-rdtsc],
+ [
+ Uses rdtsc as timing source (disabled by default)
+ Enable it when you've timing issues.
+
+ (For example: in conjunction with XEN or Other Virtualization mechanisms)
+
+ Note:
+ Please ensure that you've disabled dynamic CPU-Frequencys, such as power saving options.
+ (On the most modern Dedicated Servers cpufreq is preconfigured, see your distribution's manual
+ how to disable it)
+ ]
+ ),
+ [
+ enable_rdtsc=1
+ ],
+ [enable_rdtsc=0]
+)
#
# Profiler
@@ -384,6 +408,19 @@ esac
#
+# RDTSC
+#
+case $enable_rdtsc in
+ 0)
+ #default value
+ ;;
+ 1)
+ CFLAGS="$CFLAGS -DENABLE_RDTSC"
+ ;;
+esac
+
+
+#
# Profiler
#
case $enable_profiler in