summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2016-07-08 02:27:33 +0300
committerAndrei Karas <akaras@inbox.ru>2016-07-08 19:57:11 +0300
commit154e6b085ef4715f04b9597035b9a5e83962b545 (patch)
tree347b28259b08be61d8c21d827f5cb0a7e6d203b2 /configure.ac
parent0c3ad55e5d6533818d74fde4635fb798eb3106d6 (diff)
downloadhercules-154e6b085ef4715f04b9597035b9a5e83962b545.tar.gz
hercules-154e6b085ef4715f04b9597035b9a5e83962b545.tar.bz2
hercules-154e6b085ef4715f04b9597035b9a5e83962b545.tar.xz
hercules-154e6b085ef4715f04b9597035b9a5e83962b545.zip
Disable epoll by default and fix formatting in epoll in configure.ac
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 16 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 0e1c6b8bf..0a86ffb58 100644
--- a/configure.ac
+++ b/configure.ac
@@ -147,22 +147,25 @@ AC_ARG_ENABLE(
#
AC_ARG_ENABLE([epoll],
[AS_HELP_STRING([--enable-epoll],[use epoll(4) on Linux])],
- [enable_epoll=$enableval], [enable_epoll=auto])
+ [enable_epoll=$enableval],
+ [enable_epoll=no]
+)
if test x$enable_epoll = xno; then
have_linux_epoll=no
else
- AC_MSG_CHECKING([for Linux epoll(4)])
- AC_LINK_IFELSE([AC_LANG_PROGRAM(
- [
- #ifndef __linux__
- #error This is not Linux
- #endif
- #include <sys/epoll.h>
- ],
- [epoll_create1 (EPOLL_CLOEXEC);])],
- [have_linux_epoll=yes],
- [have_linux_epoll=no])
- AC_MSG_RESULT([$have_linux_epoll])
+ AC_MSG_CHECKING([for Linux epoll(4)])
+ AC_LINK_IFELSE([AC_LANG_PROGRAM(
+ [
+ #ifndef __linux__
+ #error This is not Linux
+ #endif
+ #include <sys/epoll.h>
+ ],
+ [epoll_create1 (EPOLL_CLOEXEC);])],
+ [have_linux_epoll=yes],
+ [have_linux_epoll=no]
+ )
+ AC_MSG_RESULT([$have_linux_epoll])
fi
if test x$enable_epoll,$have_linux_epoll = xyes,no; then
AC_MSG_ERROR([epoll support explicitly enabled but not available])