summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2017-08-16 19:40:07 +0300
committerAndrei Karas <akaras@inbox.ru>2017-08-16 19:40:07 +0300
commit8cf0fdba8fa2efca6e09a08f4c17325a7cd10a98 (patch)
tree1bb8a2ac537bd1a2f7d9123ea803a8a9cb383221 /src/Makefile.am
parentb4409352f8aae56483133b4086a580e60660f761 (diff)
downloadevol-hercules-8cf0fdba8fa2efca6e09a08f4c17325a7cd10a98.tar.gz
evol-hercules-8cf0fdba8fa2efca6e09a08f4c17325a7cd10a98.tar.bz2
evol-hercules-8cf0fdba8fa2efca6e09a08f4c17325a7cd10a98.tar.xz
evol-hercules-8cf0fdba8fa2efca6e09a08f4c17325a7cd10a98.zip
Add evol packets id offset. For now offset is 0.
This allow to change evol packets id if they start conflicting with hercules packets in future.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 8315549..86cd2a1 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -135,7 +135,8 @@ MAP_SRC = emap/atcommand.c \
# need remove -Wno-unused
SHARED_CFLAGS = ${CFLAGS} -O3 -pipe -ffast-math -std=c99 -Wall -Wextra -Wno-sign-compare -Wno-unused -fno-omit-frame-pointer \
- -DPCRE_SUPPORT -I../../.. -I../../../../3rdparty -DPACKETVER=20150513
+ -DPCRE_SUPPORT -I../../.. -I../../../../3rdparty -DPACKETVER=20150513 \
+ -DevolPacketOffset=0
SHARED_LDFLAGS = -avoid-version -Wl,--no-undefined
if ENABLE_STATIC_BUILD