summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJesusaves <cpntb1@ymail.com>2022-02-06 01:15:11 -0300
committerJesusaves <cpntb1@ymail.com>2022-02-06 01:15:11 -0300
commit9bf7e921e7807def51f32ff48ad6920618735a8d (patch)
treebc326d6fe86cb538a724d064788cbaae96ba1edf /configure.ac
parent660b9e5afc01a2db7c0a796b599f80deddc0cfd2 (diff)
downloadevol-hercules-9bf7e921e7807def51f32ff48ad6920618735a8d.tar.gz
evol-hercules-9bf7e921e7807def51f32ff48ad6920618735a8d.tar.bz2
evol-hercules-9bf7e921e7807def51f32ff48ad6920618735a8d.tar.xz
evol-hercules-9bf7e921e7807def51f32ff48ad6920618735a8d.zip
All new accounts will now have their passwords stored in SHA256.
Supersedes all previous authentication methods, except VAULT TOKEN. This is done on registration and when changing password.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ef4e156..8a89d54 100644
--- a/configure.ac
+++ b/configure.ac
@@ -330,4 +330,24 @@ AC_MSG_CHECKING([PCRE library])
AC_CHECK_HEADER([pcre.h], [], [AC_MSG_ERROR([PCRE header not found])])
AC_SEARCH_LIBS([pcre_study], [pcre], [], AC_MSG_ERROR([PCRE not found or incompatible]))
+#
+# OpenSSL library
+#
+
+AC_MSG_CHECKING([OpenSSL library])
+dnl Order matters!
+if test "$PORTNAME" != "win32"; then
+ AC_CHECK_LIB(crypto, CRYPTO_new_ex_data, [], [AC_MSG_ERROR([library 'crypto' is required for OpenSSL])])
+ FOUND_SSL_LIB="no"
+ AC_CHECK_LIB(ssl, OPENSSL_init_ssl, [FOUND_SSL_LIB="yes"])
+ AC_CHECK_LIB(ssl, SSL_library_init, [FOUND_SSL_LIB="yes"])
+ AS_IF([test "x$FOUND_SSL_LIB" = xno], [AC_MSG_ERROR([library 'ssl' is required for OpenSSL])])
+else
+ AC_SEARCH_LIBS(CRYPTO_new_ex_data, eay32 crypto, [], [AC_MSG_ERROR([library 'eay32' or 'crypto' is required for OpenSSL])])
+ FOUND_SSL_LIB="no"
+ AC_SEARCH_LIBS(OPENSSL_init_ssl, ssleay32 ssl, [FOUND_SSL_LIB="yes"])
+ AC_SEARCH_LIBS(SSL_library_init, ssleay32 ssl, [FOUND_SSL_LIB="yes"])
+ AS_IF([test "x$FOUND_SSL_LIB" = xno], [AC_MSG_ERROR([library 'ssleay32' or 'ssl' is required for OpenSSL])])
+fi
+
AC_OUTPUT(Makefile src/Makefile)