summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2016-06-24 02:05:17 +0300
committerAndrei Karas <akaras@inbox.ru>2016-06-24 02:05:17 +0300
commit3b9afaaea120dc8ba3381610c8cbdcb9b8ffb62a (patch)
treee71f09f5a00192180e5e4330557588b9804c12c5 /configure.ac
parent61a330dfb4823e6b402c7fd311da9b0c6de9b28b (diff)
downloadevol-hercules-3b9afaaea120dc8ba3381610c8cbdcb9b8ffb62a.tar.gz
evol-hercules-3b9afaaea120dc8ba3381610c8cbdcb9b8ffb62a.tar.bz2
evol-hercules-3b9afaaea120dc8ba3381610c8cbdcb9b8ffb62a.tar.xz
evol-hercules-3b9afaaea120dc8ba3381610c8cbdcb9b8ffb62a.zip
Disable sanity flags for gcc 4.8 and older.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 14 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index dc6a1c0..00e1232 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,7 +26,20 @@ AC_ARG_ENABLE(
enable_sanitize="$enableval"
case $enableval in
"no");;
- "yes");;
+ "yes")
+ if test -n "$CC"; then
+ case `($CC --version) 2>/dev/null` in
+ *gcc*4.4*| \
+ *gcc*4.5*| \
+ *gcc*4.6*| \
+ *gcc*4.7*| \
+ *gcc*4.8*)
+ enable_sanitize="no"
+ ;;
+ *);;
+ esac
+ fi
+ ;;
*) AC_MSG_ERROR([[invalid argument --enable-sanitize=$disableval... stopping]]);;
esac
],