summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac35
1 files changed, 1 insertions, 34 deletions
diff --git a/configure.ac b/configure.ac
index 839f59080..f1aa8bb52 100755
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
AC_PREREQ(2.60)
-AC_INIT([ManaPlus], [1.4.2.15], [akaras@inbox.ru], [manaplus])
+AC_INIT([ManaPlus], [1.4.3.1], [akaras@inbox.ru], [manaplus])
AM_INIT_AUTOMAKE([1.9])
AC_CONFIG_HEADERS([config.h:config.h.in])
AC_LANG_CPLUSPLUS
@@ -249,28 +249,6 @@ else
fi
AM_CONDITIONAL(USE_OPENGL, test x$with_opengl = xyes)
-# Option to enable internal guichan
-AC_ARG_WITH(internalguichan,[ --without-internalguichan DEPRICATED. don't use internal guichan ] )
-if test "x$with_internalguichan" == "xno"; then
- with_internalguichan=no
-
- AC_CHECK_LIB([guichan], [gcnGuichanVersion], ,
- AC_MSG_ERROR([ *** Unable to find Guichan library (http://guichan.sf.net/)]))
- AC_CHECK_HEADERS([guichan.hpp], ,
- AC_MSG_ERROR([ *** Guichan library found but cannot find headers (http://guichan.sf.net/)]))
-
- AC_CHECK_HEADERS([guichan/widgetlistener.hpp], ,
- AC_MSG_ERROR([ *** Guichan library version is found but version is < 0.8.0 (http://guichan.sf.net/)]))
-
- AC_CHECK_LIB([guichan_sdl], [gcnSDL], ,
- AC_MSG_ERROR([ *** Unable to find Guichan SDL library (http://guichan.sf.net/)]))
-
-else
- with_internalguichan=yes
- AC_DEFINE(USE_INTERNALGUICHAN, 1, [Defines if ManaPlus should use internal guichan classes])
-fi
-AM_CONDITIONAL(USE_INTERNALGUICHAN, test x$with_internalguichan = xyes)
-
# Option to enable mumble support
AC_ARG_WITH(mumble,[ --without-mumble don't use mumble integration ] )
if test "x$with_mumble" == "xno"; then
@@ -298,17 +276,6 @@ else
without_librt=no
fi
-# Enable manaserv
-AC_ARG_ENABLE(manaserv,
-[ --enable-manaserv Turn on manaserv support],
-[case "${enableval}" in
- yes) with_manaserv=true ;;
- no) with_manaserv=false ;;
- *) AC_MSG_ERROR(bad value ${enableval} for --enable-manaserv) ;;
-esac],[with_manaserv=false])
-
-AM_CONDITIONAL(ENABLE_MANASERV, test x$with_manaserv = xtrue)
-
# Enable eAthena
AC_ARG_ENABLE(eathena,
[ --enable-eathena Turn on eAthena support],