summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2017-10-25 20:02:28 +0300
committerAndrei Karas <akaras@inbox.ru>2017-10-25 20:02:28 +0300
commit7bbd39e0da04cee932f4afe6a4c85ebb78f39a81 (patch)
tree220a6f44ff80ed1d5242ab469d91ce4a28e03f72 /src/Makefile.am
parent880fa28099e828821378a9c83a7218ae5bfa3110 (diff)
downloadplus-7bbd39e0da04cee932f4afe6a4c85ebb78f39a81.tar.gz
plus-7bbd39e0da04cee932f4afe6a4c85ebb78f39a81.tar.bz2
plus-7bbd39e0da04cee932f4afe6a4c85ebb78f39a81.tar.xz
plus-7bbd39e0da04cee932f4afe6a4c85ebb78f39a81.zip
Add configure options for build with system catch and doctest.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 7f22f0507..1b7ccd77f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -37,6 +37,9 @@ endif
if ENABLE_UNITTESTSBIN_DOCTEST
manaplustests_CXXFLAGS += -DUNITTESTS_DOCTEST
endif
+if ENABLE_UNITTESTS_EMBED
+manaplustests_CXXFLAGS += -DUNITTESTS_EMBED
+endif
dyecmd_CXXFLAGS = -DPKG_DATADIR=\""$(pkgdatadir)/"\" \
-DLOCALEDIR=\""$(localedir)"\" \