summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2015-06-07 20:35:27 +0300
committerAndrei Karas <akaras@inbox.ru>2015-06-07 20:35:27 +0300
commitffd432add542852a4e3bae3ae477369fed4e0147 (patch)
treedb963887019c3a46b85243ba07f1d13e8ece2c20 /configure.ac
parentea5da3bc3337b3125b780f7c24adbc1a73b5765b (diff)
downloadplus-ffd432add542852a4e3bae3ae477369fed4e0147.tar.gz
plus-ffd432add542852a4e3bae3ae477369fed4e0147.tar.bz2
plus-ffd432add542852a4e3bae3ae477369fed4e0147.tar.xz
plus-ffd432add542852a4e3bae3ae477369fed4e0147.zip
Add configure option for enable gcc check plugin.
New configure option: --enable-checkplugin
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fda56bbce..5c4223679 100755
--- a/configure.ac
+++ b/configure.ac
@@ -378,6 +378,17 @@ esac],[cilkplus_enabled=false])
AM_CONDITIONAL(ENABLE_CILKPLUS, test x$cilkplus_enabled = xtrue)
+# Enable gcc check plugin
+AC_ARG_ENABLE(checkplugin,
+[ --enable-checkplugin Turn on gcc check plugin],
+[case "${enableval}" in
+ yes) checkplugin_enabled=true ;;
+ no) checkplugin_enabled=false ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-checkplugin) ;;
+esac],[checkplugin_enabled=false])
+
+AM_CONDITIONAL(ENABLE_CHECKPLUGIN, test x$checkplugin_enabled = xtrue)
+
AC_CONFIG_FILES([
manaplus.spec
Makefile