summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2017-10-09 20:19:48 +0300
committerAndrei Karas <akaras@inbox.ru>2017-10-09 20:19:48 +0300
commitcd6b02aed24b4f9e2899bb9b58ff84a2afe0896d (patch)
tree3f8f5b88ffa1ff6f01bafa5149364d4eb9f8fa59 /configure.ac
parent30ba0c39fa249a3f5588e1299e5618f5f168097a (diff)
downloadplus-cd6b02aed24b4f9e2899bb9b58ff84a2afe0896d.tar.gz
plus-cd6b02aed24b4f9e2899bb9b58ff84a2afe0896d.tar.bz2
plus-cd6b02aed24b4f9e2899bb9b58ff84a2afe0896d.tar.xz
plus-cd6b02aed24b4f9e2899bb9b58ff84a2afe0896d.zip
Add support for configure parameter for override home dir for unit tests.
New configure parameter: --with-unittestsdir=path
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7d16fde20..ecc6ee35a 100755
--- a/configure.ac
+++ b/configure.ac
@@ -667,6 +667,15 @@ AM_CONDITIONAL(ENABLE_UNITTESTSBIN, test x$unittestsbin_enabled = xtrue)
AM_CONDITIONAL(ENABLE_UNITTESTSBIN_CATCH, test x$unittestsbin_catch = xtrue)
AM_CONDITIONAL(ENABLE_UNITTESTSBIN_DOCTEST, test x$unittestsbin_doctest = xtrue)
+# Override home directory for unit tests
+AC_ARG_WITH(unittestsdir,[ --with-unittestsdir override home directory for unit tests ] )
+if test "x$with_unittestsdir" == "xno"; then
+ with_unittestsdir=no
+else
+ with_unittestsdir=yes
+ CPPFLAGS="$CPPFLAGS -DUNITESTSDIR=$withval"
+fi
+
# Enable tcmalloc
AC_ARG_ENABLE(tcmalloc,
[ --enable-tcmalloc Turn on tcmalloc],