summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2015-04-24 02:11:35 +0300
committerAndrei Karas <akaras@inbox.ru>2015-04-24 02:13:45 +0300
commitc5e54ca6234d9568e1185e1ff92f4d04c41faa6c (patch)
treeed5a86099956c00753d410dc637388480971a808 /configure.ac
parent4e6c08b939fbfb1cd4a8a5653bd16d285b55150c (diff)
downloadplus-c5e54ca6234d9568e1185e1ff92f4d04c41faa6c.tar.gz
plus-c5e54ca6234d9568e1185e1ff92f4d04c41faa6c.tar.bz2
plus-c5e54ca6234d9568e1185e1ff92f4d04c41faa6c.tar.xz
plus-c5e54ca6234d9568e1185e1ff92f4d04c41faa6c.zip
Add configure option for enable/disable CilkPlus support.
By default disabled.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index dbf134319..d8abded8c 100755
--- a/configure.ac
+++ b/configure.ac
@@ -368,6 +368,17 @@ esac],[googleprofiler_enabled=false])
AM_CONDITIONAL(ENABLE_GOOGLE_PROFILER, test x$googleprofiler_enabled = xtrue)
+# Enable cilk plus
+AC_ARG_ENABLE(cilkplus,
+[ --enable-cilkplus Turn on parallelisation with CilkPlus],
+[case "${enableval}" in
+ yes) cilkplus_enabled=true ;;
+ no) cilkplus_enabled=false ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-cilkplus) ;;
+esac],[cilkplus_enabled=false])
+
+AM_CONDITIONAL(ENABLE_CILKPLUS, test x$cilkplus_enabled = xtrue)
+
AC_CONFIG_FILES([
manaplus.spec
Makefile