summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2017-07-13 22:49:03 +0300
committerAndrei Karas <akaras@inbox.ru>2017-07-13 22:49:03 +0300
commitc3b4284ee079539892e510f7ccd1768c793e9b5f (patch)
tree0dcdbe3a187c85008aa229c401107f0e6c429656 /configure.ac
parentf2b51ca5984fc464fbcee652b13c0287752d3c7a (diff)
downloadplus-c3b4284ee079539892e510f7ccd1768c793e9b5f.tar.gz
plus-c3b4284ee079539892e510f7ccd1768c793e9b5f.tar.bz2
plus-c3b4284ee079539892e510f7ccd1768c793e9b5f.tar.xz
plus-c3b4284ee079539892e510f7ccd1768c793e9b5f.zip
Add mse libs for replacing std::vector.
Also add configure flag --enable-stldebug For now unused.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6ee8ce327..8da4ee8d0 100755
--- a/configure.ac
+++ b/configure.ac
@@ -92,6 +92,19 @@ esac],[glibcdebug_enabled=false])
AM_CONDITIONAL(ENABLE_GLIBCDEBUG, test x$glibcdebug_enabled = xtrue)
+# Enable mse classes replacements for stl
+AC_ARG_ENABLE(stldebug,
+[ --enable-stldebug Enable mse libs],
+[case "${enableval}" in
+ yes) stldebug_enabled=true
+ ;;
+ no) stldebug_enabled=false
+ ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-stldebug) ;;
+esac],[stldebug_enabled=false])
+
+AM_CONDITIONAL(ENABLE_STLDEBUG, test x$stldebug_enabled = xtrue)
+
# Enable OpenGL error reporting
AC_ARG_ENABLE(openglerrors,
[ --enable-openglerrors Enable OpenGL errors reporting],