summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2017-07-05 23:22:07 +0300
committerAndrei Karas <akaras@inbox.ru>2017-07-06 00:15:43 +0300
commit894ac6d2f85e1de3964a22aa49fa375770e7e5cf (patch)
tree10a652e85f252dee5fad5b4d74945276d0597979 /configure.ac
parent534d25d85e9a9521042be025cdff86db8357c766 (diff)
downloadplus-894ac6d2f85e1de3964a22aa49fa375770e7e5cf.tar.gz
plus-894ac6d2f85e1de3964a22aa49fa375770e7e5cf.tar.bz2
plus-894ac6d2f85e1de3964a22aa49fa375770e7e5cf.tar.xz
plus-894ac6d2f85e1de3964a22aa49fa375770e7e5cf.zip
Fix icu-59 and libxml2 issue.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 1da07677c..3de8a975b 100755
--- a/configure.ac
+++ b/configure.ac
@@ -402,15 +402,20 @@ if test "$xmllib" == "libxml"; then
AC_CHECK_HEADERS(
[libxml/xmlreader.h],
,
- CPPFLAGS="$CPPFLAGS `$ICU_CONFIG --cxxflags`"
+ # workaround for icu-59 issue.
+ CPPFLAGS="$CPPFLAGS --std=c++0x"
AC_MSG_RESULT([no])
AC_MSG_CHECKING([Checking libxml2 headers with icu bug fix])
+ icu_bug=yes
+ $as_unset ac_cv_header_libxml_xmlreader_h
+ )
+ if test "$icu_bug" == "yes"; then
AC_CHECK_HEADERS(
[libxml/xmlreader.h],
,
AC_MSG_ERROR([ *** libxml2 library found but cannot find headers (http://xmlsoft.org/)])
)
- )
+ fi
fi
if test "$xmllib" == "pugixml"; then