summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2017-03-28 04:10:23 +0300
committerAndrei Karas <akaras@inbox.ru>2017-03-28 04:10:23 +0300
commit6ff6d6928328ff2110f028a374ade49415d5a0ba (patch)
tree4337ddc2e83368a2d606b97df08dc206e002ac67 /configure.ac
parent475aea387f846561d5029807f804ff789d59e69f (diff)
downloadplus-6ff6d6928328ff2110f028a374ade49415d5a0ba.tar.gz
plus-6ff6d6928328ff2110f028a374ade49415d5a0ba.tar.bz2
plus-6ff6d6928328ff2110f028a374ade49415d5a0ba.tar.xz
plus-6ff6d6928328ff2110f028a374ade49415d5a0ba.zip
Remove physfs support.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac16
1 files changed, 0 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index dd51ff4a8..834087ede 100755
--- a/configure.ac
+++ b/configure.ac
@@ -331,21 +331,6 @@ if test "$skip_check_lib" == "no"; then
AC_MSG_ERROR([ *** Unable to find zlib (http://www.gzip.org/zlib/)]))
fi
-# Option to enable physfs.
-AC_ARG_WITH(physfs,[ --with-physfs use physfs (experimental) ] )
-if test "x$with_physfs" == "xyes"; then
- with_physfs=yes
- if test "$skip_check_lib" == "no"; then
- AC_CHECK_LIB([physfs], [PHYSFS_init], ,
- AC_MSG_ERROR([ *** Unable to find PhysFS library (http://icculus.org/physfs/)]))
- fi
- AC_CHECK_HEADERS([physfs.h], ,
- AC_MSG_ERROR([ *** PhysFS library found but cannot find headers (http://icculus.org/physfs/)]))
-else
- with_physfs=no
-fi
-AM_CONDITIONAL(USE_PHYSFS, test x$with_physfs = xyes)
-
if test -n "$CURL_CONFIG"; then
LIBS="$LIBS `$CURL_CONFIG --libs`"
CPPFLAGS="$CPPFLAGS `$CURL_CONFIG --cflags`"
@@ -738,7 +723,6 @@ if test "$unittests_enabled" == true; then
fi
echo "Build with OpenGL: $with_opengl"
-echo "Build with physfs: $with_physfs"
echo
echo "LIBS: $LIBS"
echo "CPPFLAGS: $CPPFLAGS"