summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2017-01-19 16:08:43 +0300
committerAndrei Karas <akaras@inbox.ru>2017-01-19 16:39:11 +0300
commit623a64f2c96b71f8609eccb81cb04886ae390c7b (patch)
tree1d9c782f26e3e4a4dba2dfc53de5729f8c2684ff /configure.ac
parentb7c9e3c0fd5b17c6964c81bb742c2cef1630d50e (diff)
downloadplus-623a64f2c96b71f8609eccb81cb04886ae390c7b.tar.gz
plus-623a64f2c96b71f8609eccb81cb04886ae390c7b.tar.bz2
plus-623a64f2c96b71f8609eccb81cb04886ae390c7b.tar.xz
plus-623a64f2c96b71f8609eccb81cb04886ae390c7b.zip
Dump on startup linked and loaded lib versions.
For now only zlib supported. Also detect zlib by pkgconfig in configure.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac15
1 files changed, 11 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 0257e96cc..b6655bd6e 100755
--- a/configure.ac
+++ b/configure.ac
@@ -105,6 +105,13 @@ AC_TYPE_UINT32_T
AC_TYPE_INT64_T
AC_TYPE_SSIZE_T
+# Search for *-config
+AC_PATH_PROG(PKG_CONFIG, pkg-config)
+AC_PATH_PROG(CURL_CONFIG, curl-config)
+
+LIBS="$LIBS `$PKG_CONFIG --libs zlib`"
+CPPFLAGS="$CPPFLAGS `$PKG_CONFIG --cflags zlib`"
+
# Checks for internationalization support
AM_GNU_GETTEXT([external],[need-ngettext])
AM_GNU_GETTEXT_VERSION([0.16.1])
@@ -192,10 +199,6 @@ if test "x$naclbuild_enabled" == "xfalse"; then
AC_CHECK_SDL()
fi
-# Search for *-config
-AC_PATH_PROG(PKG_CONFIG, pkg-config)
-AC_PATH_PROG(CURL_CONFIG, curl-config)
-
# Checks for libraries
AC_ARG_WITH(pthread,[ --without-pthread don't check for pthread ] )
if test "x$with_pthread" == "xno"; then
@@ -545,5 +548,9 @@ AC_OUTPUT
echo
echo "Build with OpenGL: $with_opengl"
echo
+echo "LIBS: $LIBS"
+echo "CPPFLAGS: $CPPFLAGS"
+
+echo
echo "configure complete, now type \"make\""
echo