summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2012-10-17 02:24:54 +0300
committerAndrei Karas <akaras@inbox.ru>2012-10-17 14:55:08 +0300
commit5a322df4da3102ae0c8d3bc3071386dc5f21e580 (patch)
tree4ca0cca3328baf7484074ad6e1cf9c5a9f9e3db0 /configure.ac
parente6e36b25a696212f0262e3e5ef520543b1b3a58b (diff)
downloadplus-5a322df4da3102ae0c8d3bc3071386dc5f21e580.tar.gz
plus-5a322df4da3102ae0c8d3bc3071386dc5f21e580.tar.bz2
plus-5a322df4da3102ae0c8d3bc3071386dc5f21e580.tar.xz
plus-5a322df4da3102ae0c8d3bc3071386dc5f21e580.zip
Add OpenGL support for Android builds (partially).
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a4e9f68f0..512f42dfa 100755
--- a/configure.ac
+++ b/configure.ac
@@ -152,8 +152,13 @@ if test "x$with_opengl" == "xno"; then
else
with_opengl=yes
if test "x$applebuild_enabled" == "xfalse"; then
- AC_CHECK_LIB([GL], [glBegin], ,
- AC_MSG_ERROR([ *** Unable to find OpenGL library]))
+
+ if test "x$androidbuild_enabled" == "xfalse"; then
+ AC_CHECK_LIB([GL], [glBegin], ,
+ AC_MSG_ERROR([ *** Unable to find OpenGL library]))
+ else
+ LDFLAGS="$LDFLAGS -lGLESv2 -lEGL"
+ fi
else
LDFLAGS="$LDFLAGS -framework OpenGL"
fi