summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2015-09-12 20:05:22 +0300
committerAndrei Karas <akaras@inbox.ru>2015-09-12 20:05:22 +0300
commit540b40ba1f1806c8b3eca10c101f2457230c490d (patch)
treeb1c4ddb1a1771f0db5b3018c8ba3f5670950b989 /configure.ac
parent906e0791682825606f80f72f067f4b19005fe535 (diff)
downloadplus-540b40ba1f1806c8b3eca10c101f2457230c490d.tar.gz
plus-540b40ba1f1806c8b3eca10c101f2457230c490d.tar.bz2
plus-540b40ba1f1806c8b3eca10c101f2457230c490d.tar.xz
plus-540b40ba1f1806c8b3eca10c101f2457230c490d.zip
Add option for build dyecmd.
New configure option: --width-dyecmd By default enabled.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac15
1 files changed, 14 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1dc58b62b..c87f51dca 100755
--- a/configure.ac
+++ b/configure.ac
@@ -9,13 +9,26 @@ AC_ARG_ENABLE(androidbuild,
[ --enable-androidbuild Turn on android building],
[case "${enableval}" in
yes) androidbuild_enabled=true
+ dyecmd_enabled=false
;;
no) androidbuild_enabled=false
;;
*) AC_MSG_ERROR(bad value ${enableval} for --enable-androidbuild) ;;
esac],[androidbuild_enabled=false])
-AM_CONDITIONAL(ENABLE_DYECMD, test x$androidbuild_enabled != xyes)
+# Enable for dyecmd
+AC_ARG_WITH(dyecmd,[ --with-dyecmd build dyecmd tool ] )
+if test "x$with_dyecmd" == "xno"; then
+ with_dyecmd=no
+else
+ if test "x$androidbuild_enabled" == "xfalse"; then
+ with_dyecmd=yes
+ else
+ with_dyecmd=no
+ fi
+fi
+
+AM_CONDITIONAL(ENABLE_DYECMD, test x$with_dyecmd = xyes)
# Enable nacl build
AC_ARG_ENABLE(naclbuild,