summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Sagunov <danilka.pro@gmail.com>2012-10-15 19:11:28 +0400
committerDan Sagunov <danilka.pro@gmail.com>2012-10-15 19:11:28 +0400
commit5279cc2c5b734c4a86c591c52358cde9d63e5520 (patch)
treea8d6f8e4210cbe3e813caa2af60cb248cc0be512 /configure.ac
parent37e870866404d8065d732d785e3086699d6834fc (diff)
downloadplus-5279cc2c5b734c4a86c591c52358cde9d63e5520.tar.gz
plus-5279cc2c5b734c4a86c591c52358cde9d63e5520.tar.bz2
plus-5279cc2c5b734c4a86c591c52358cde9d63e5520.tar.xz
plus-5279cc2c5b734c4a86c591c52358cde9d63e5520.zip
Added androidbuild check in librt, mumble and pthread
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac18
1 files changed, 13 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 56d28c307..a4e9f68f0 100755
--- a/configure.ac
+++ b/configure.ac
@@ -50,8 +50,10 @@ AC_ARG_WITH(pthread,[ --without-pthread don't check for pthread ] )
if test "x$with_pthread" == "xno"; then
without_pthread=yes
else
- AC_CHECK_LIB([pthread], [pthread_create], ,
- AC_MSG_ERROR([ *** Unable to find pthread library]))
+ if test "x$androidbuild_enabled" == "xfalse"; then
+ AC_CHECK_LIB([pthread], [pthread_create], ,
+ AC_MSG_ERROR([ *** Unable to find pthread library]))
+ fi
withoud_pthread=no
fi
@@ -188,7 +190,11 @@ AC_ARG_WITH(internalguichan,[ --without-mumble don't use mumble integrat
if test "x$with_mumble" == "xno"; then
with_mumble=no
else
- with_mumble=yes
+ if test "x$androidbuild_enabled" == "xfalse"; then
+ with_mumble=yes
+ else
+ with_mumble=no
+ fi
fi
AM_CONDITIONAL(USE_MUMBLE, test x$with_mumble = xyes)
@@ -201,8 +207,10 @@ if test "x$with_librt" == "xno"; then
without_librt=yes
else
if test "x$applebuild_enabled" == "xfalse"; then
- AC_CHECK_LIB(rt, shm_open, ,
- AC_MSG_ERROR([ *** Unable to find librt library]))
+ if test "x$androidbuild_enabled" == "xfalse"; then
+ AC_CHECK_LIB(rt, shm_open, ,
+ AC_MSG_ERROR([ *** Unable to find librt library]))
+ fi
fi
without_librt=no
fi