summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2016-01-02 22:54:36 +0300
committerAndrei Karas <akaras@inbox.ru>2016-01-03 00:46:28 +0300
commit519c2796e52ea933f6de5a490aee1f1ab826ea5e (patch)
tree01205558a568663d1c1ff67fda39ee84ce4051ec /configure.ac
parent2d2bbb2fe5a0dc55cbf5b9616a78500704b6ea65 (diff)
downloadplus-519c2796e52ea933f6de5a490aee1f1ab826ea5e.tar.gz
plus-519c2796e52ea933f6de5a490aee1f1ab826ea5e.tar.bz2
plus-519c2796e52ea933f6de5a490aee1f1ab826ea5e.tar.xz
plus-519c2796e52ea933f6de5a490aee1f1ab826ea5e.zip
Add support for custom NLS (without gettext).
Add configure flag --enable-customnls Add empty directory in data/translations/manaplus for suctom translations (po files from /po directory)
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e6857f0f7..a27b69c19 100755
--- a/configure.ac
+++ b/configure.ac
@@ -409,6 +409,17 @@ esac],[checkplugin_enabled=false])
AM_CONDITIONAL(ENABLE_CHECKPLUGIN, test x$checkplugin_enabled = xtrue)
+# Enable custom NLS
+AC_ARG_ENABLE(customnls,
+[ --enable-customnls Turn on build in translation system (NLS)],
+[case "${enableval}" in
+ yes) customnls_enabled=true ;;
+ no) customnls_enabled=false ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-customnls) ;;
+esac],[customnls_enabled=false])
+
+AM_CONDITIONAL(ENABLE_CUSTOMNLS, test x$customnls_enabled = xtrue)
+
if test "x$naclbuild_enabled" == "xtrue"; then
AC_CHECK_SDL()
fi