summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrei Karas <akaras@inbox.ru>2016-05-31 01:47:53 +0300
committerAndrei Karas <akaras@inbox.ru>2016-05-31 01:47:53 +0300
commit4530a341c65ac12e50075fb3e3d6166cd2e1fe3b (patch)
tree9739fdefed4477751bee9fc07b1fbfeac1e3d1b5 /configure.ac
parentf592e589f9b5e38e1fe9e6d0fd5d2adc62326bb7 (diff)
downloadplus-4530a341c65ac12e50075fb3e3d6166cd2e1fe3b.tar.gz
plus-4530a341c65ac12e50075fb3e3d6166cd2e1fe3b.tar.bz2
plus-4530a341c65ac12e50075fb3e3d6166cd2e1fe3b.tar.xz
plus-4530a341c65ac12e50075fb3e3d6166cd2e1fe3b.zip
Add USE_X11 define into make file.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7aad4ed33..fd715eb59 100755
--- a/configure.ac
+++ b/configure.ac
@@ -276,6 +276,7 @@ AC_CHECK_LIB(png, png_write_info, ,
AC_MSG_ERROR([ *** Unable to find png library]))
+use_x11=no
# === Check for X11 (check borrowed from Wormux) ========================
# Deactivated on purpose under OSX (in case X11 SDK is installed)
if test "x$OSX" != "xyes" ; then
@@ -289,11 +290,15 @@ if test "x$OSX" != "xyes" ; then
if test x${check_x11} = xyes ; then
AC_CHECK_LIB(X11, XOpenDisplay,
[ LIBS="$LIBS -lX11"
- AC_DEFINE(USE_X11, 1, [Define to use X11 copy'n'paste]) ],
+ AC_DEFINE(USE_X11, 1, [Define to use X11 copy'n'paste])
+ use_x11=yes
+ ],
[])
fi
fi
+AM_CONDITIONAL(USE_X11, test x$use_x11 = xyes)
+
# Checks for header files.
AC_HEADER_STDC
AC_CHECK_HEADERS([arpa/inet.h fcntl.h malloc.h netdb.h netinet/in.h stdlib.h string.h sys/socket.h unistd.h])